Cisco Single BGP with AS prepend
|
[CPE/Customer Cisco Router]
Current configuration:
!
version 12.x
!
hostname CPE
!
!
interface Ethernet0
description to Internal network
ip address 10.1.0.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
!
interface Serial0
description to ISP
ip address 12.1.3.1 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip mroute-cache
no ip directed-broadcast
shutdown
!
router bgp 10no auto-summary
network 10.1.0.0 mask 255.255.255.0
neighbor 12.1.3.2 remote-as 20 <—- 20 is ISP’s ASN
neighbor 12.1.3.2 version 4
neighbor 12.1.3.2 route-map To_ISP out
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0 <—– Default route, if partial routes are receiving from ISP, you must have this default route statement. You can request ISP to send default route through BGP.
!
ip prefix-list 1 description announcing routes to ISP
ip prefix-list 1 seq 5 permit 10.1.0.0/24 le 32
!
route-map To_ISP permit 10
match ip address prefix-list 1
set as-path prepend 10 10 10 <—- AS prepended three times
!
line con 0
line aux 0
line vty 0 4
login
!
end
[PE / ISP Cisco Router]
Current configuration:
!
version 12.x
!
hostname PE
!
!
interface Serial0
description to ISP
ip address 12.1.3.2 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
no ip mroute-cache
no ip directed-broadcast
shutdown
!
router bgp 20
neighbor 12.1.3.1 remote-as 10 <—- 10 is other side’s ASN
neighbor 12.1.3.1 version 4
neighbor 12.1.3.1 default-originate <—- Sending default route to customer through BGP.
neighbor 12.1.3.1 prefix-list 2 in
!
ip classless
!
ip prefix-list 2 description from customer or peer
ip prefix-list 2 seq 5 permit 10.1.0.0/24 le 32 <—- Accepting smaller block than /24
!
line con 0
line aux 0
line vty 0 4
login
!
end
[Verifing output]
CPE# show ip bgp neighbors 12.1.3.2 ad
BGP table version is 8, local router ID is x.x.x.x
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal
Origin codes: i – IGP, e – EGP, ? – incompleteNetwork Next Hop Metric LocPrf Weight Path
*> 10.1.0.0/24 0.0.0.0 0 0 32768 ?
CPE#
PE#show ip bgp neighbors 12.1.3.1 ro
BBGP table version is 245, local router ID is x.x.x.x
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal
Origin codes: i – IGP, e – EGP, ? – incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.1.0.0/24 12.1.3.1 0 0 10 10 10 10 ? <—- AS prepended three times
Total number of prefixes 1
CPE#show ip bgp neighbors 12.1.3.2 ro <—- Getting default route from ISP
BGP table version is 10, local router ID is x.x.x.x
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal
Origin codes: i – IGP, e – EGP, ? – incomplete
Network NextHop Metric LocPrf Weight Path
*> 0.0.0.0 12.1.3.2 0 20 i
Total number of prefixes 1
CPE#
If you have any questions, feel free to send email us at [email protected]. If you are looking for professional grade service, you might want to try our "BGP experts service". What is "BGP Experts service"? Click "BGP Experts" from the top menu option. You will find out what the "BGP Experts" and what we are doing here for.
Recent Comments