3-3-1. Cisco dual BGP with AS prepend (Redundancy)

BGP sample configuration 3-3-1

Cisco dual BGP with AS prepend (Redundancy)

   
  • ISPs : 1
  • WAN links : 2
  • CPE : 1
  • PE : 2
  • Device : Cisco router with LAN/WAN ports.
  • WAN1 / Serial IP : 12.1.3.0/30 (mask 255.255.255.252)
  • WAN2 / Serial IP : 12.1.4.0/30 (mask 255.255.255.252)
  • Destination IP : 100.100.100.100 and 200.200.200.200
  • LAN / Ethernet IP : 10.1.0.1/24 and 10.1.0.129/25(Secondary)
  • Receiving Route : Default route + full route from ISP
  • Memory : Full route(recommend 512M), partial route
    (recommend 128-256M)
  • LAN : ISP (AS20) and Customer (AS10)

 

BGP sample configuration 3-3-1

[Traffic flow]

Outbound traffic on CPE
 

All outbound traffic will go out thru primary line(12.1.3.1) due to secondary link has route-map shadow_inbound prepends AS twice on default route from BGP peer(12.1.4.2)

 

 
Inbound traffic on CPE
All inbound traffic will come in thru primary line (12.1.3.1) due to secondary link has route-map shadow_outbound prepends AS twice  on announcement to uplink.

[CPE/Customer Cisco Router]

Current configuration:
!
version 12.x
!
hostname CPE
!
interface Ethernet0
description to Internal network
ip address 10.1.0.1 255.255.255.0
ip address 10.1.0.129 255.255.255.128 secondary
no ip directed-broadcast
no ip mroute-cache
!
interface Serial0
description to ISP A – WAN 1
ip address 12.1.3.1 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
description to ISP A – WAN 2
ip address 12.1.4.1 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
router bgp 10
no auto-summary
network 10.1.0.0 mask 255.255.255.0
neighbor 12.1.3.2 remote-as 20
neighbor 12.1.3.2 version 4
neighbor 12.1.3.2 prefix-list 1 out
neighbor 12.1.3.2 filter-list 10 out <– To prevent announcing routes that is learning from other link or ISP
neighbor 12.1.4.2 remote-as 20
neighbor 12.1.4.2 version 4
neighbor 12.1.4.2 prefix-list 1 out
neighbor 12.1.3.2 filter-list 10 out <– To prevent announcing routes that is learning from other link or ISP
neighbor 12.1.4.2 route-map shadow_inbound in
neighbor 12.1.4.2 route-map shadow_outbound out
!
ip classless
!
ip as-path access-list 10 permit ^$
ip prefix-list 1 seq 5 permit 10.1.0.0/24
 

!
route-map shadow_inbound permit 10

 

set as-path prepend 10 10

 

!

 

route-map shadow_outbound permit 10

set as-path prepend 10 10
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

[PE1 / ISP Cisco Router]

Current configuration:
!
version 12.x
!
hostname PE
!
!
interface Serial0
description to WAN 1
ip address 12.1.3.2 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
 

router bgp 20
no auto-summary
neighbor 12.1.3.1 remote-as 10
neighbor 12.1.3.1 version 4
neighbor 12.1.3.1 default-originate <—to send a default route

neighbor 12.1.3.1 distribute-list 2 out
!
ip classless
!
access-list 2 permit 100.100.100.0 0.0.0.255
access-list 2 permit 200.200.200.0 0.0.0.255 
line con 0
line aux 0
line vty 0 4
login
!
end
[PE2 / ISP Cisco Router]
Current configuration:
!
version 12.x
!
hostname PE
!
!
interface Serial1
description to WAN 2
ip address 12.1.4.2 255.255.255.252
no ip mroute-cache
no ip directed-broadcast
no fair-queue
!
 

router bgp 20
no auto-summary
neighbor 12.1.4.1 remote-as 10
neighbor 12.1.4.1 version 4
neighbor 12.1.4.1 default-originate <—to send a default route

neighbor 12.1.4.1 distribute-list 2 out
!
ip classless
!
access-list 2 permit 100.100.100.0 0.0.0.255
access-list 2 permit 200.200.200.0 0.0.0.255
!
line con 0
line aux 0
line vty 0 4
login
!
end

 [Verifing output]

CPE#show ip bgp
BGP table version is 7, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          12.1.3.2                 0             0 20 i
*                   12.1.4.2                 0             0 10 10 20 i
*> 10.1.0.0/24      0.0.0.0                  0         32768 i
*> 100.100.100.0/24 12.1.3.2                               0 20 ?
*                   12.1.4.2                               0 10 10 20 ?
*> 200.200.200.0    12.1.3.2                               0 20 ?
*                   12.1.4.2                               0 10 10 20 ?
CPE#
 

CPE# show ip bgp neighbors 12.1.3.2 ad
BGP table version is 7, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.0.0/24      0.0.0.0                  0         32768 i

Total number of prefixes 1
CPE#
 

CPE# show ip bgp neighbors 12.1.4.2 ad
BGP table version is 7, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.0.0/24      0.0.0.0                  0         32768 i

Total number of prefixes 1
CPE#

CPE# show ip bgp neighbors 12.1.3.2 ro
BGP table version is 7, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          12.1.3.2                 0             0 20 i
*> 100.100.100.0/24 12.1.3.2                               0 20 ?
*> 200.200.200.0    12.1.3.2                               0 20 ?

Total number of prefixes 3
CPE#

CPE# show ip bgp neighbors 12.1.4.2 ro
BGP table version is 7, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  0.0.0.0          12.1.4.2                 0             0 10 10 20 i
*  100.100.100.0/24 12.1.4.2                               0 10 10 20 ?
*  200.200.200.0    12.1.4.2                               0 10 10 20 ?

Total number of prefixes 3
CPE# 

PE1#show ip bgp nei 12.1.3.1 ro
BGP table version is 58, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.0.0/24      12.1.3.1                 0             0 10 i

Total number of prefixes 1
PE1#

 
 
PE2#show ip bgp nei 12.1.4.1 ro
BGP table version is 90, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.0.0/24      12.1.4.1                 0             0 10 10 10 i

Total number of prefixes 1
PE2#
 

 
PE1#show ip bgp nei 12.1.3.1 ad
BGP table version is 58, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

Originating default network 0.0.0.0

   Network          Next Hop            Metric LocPrf Weight Path
*>i100.100.100.0/24 5.5.5.5                  0    100      0 ?
*>i200.200.200.0    5.5.5.5                  0    100      0 ?

Total number of prefixes 2
PE1#

 

PE2#show ip bgp nei 12.1.4.1 ad
BGP table version is 90, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

Originating default network 0.0.0.0

   Network          Next Hop            Metric LocPrf Weight Path
*>i100.100.100.0/24 5.5.5.5                  0    100      0 ?
*>i200.200.200.0    5.5.5.5                  0    100      0 ?

Total number of prefixes 2
PE2#

Internet#traceroute 10.1.0.1

Type escape sequence to abort.
Tracing the route to 10.1.0.1

  1 PE1 (20.3.5.1) 20 msec 28 msec 28 msec
  2 CPE (12.1.3.1) 56 msec *  64 msec

 

Internet#traceroute 10.1.0.129

Type escape sequence to abort.
Tracing the route to 10.1.0.129

  1 PE1 (20.3.5.1) 20 msec 28 msec 28 msec
  2 CPE (12.1.3.1) 52 msec *  52 msec
XR1#

If you have any questions, feel free to send email us at [email protected]. If you are looking for professional grade service, you might want to try our "BGP experts service". What is "BGP Experts service"? Click "BGP Experts" from the top menu option. You will find out what the "BGP Experts" and what we are doing here for.

 

Author: Chris Yoon

IT professional