2-1-1. Cisco Single BGP with Multi-hop (load-balancing)

BGP sample configuration 2-1-1

Cisco Single BGP with Multi-hop (load-balancing)

   
  • ISPs : 1
  • WAN links : 2
  • CPE : 1
  • PE : 1
  • Device : Cisco router with LAN/WAN ports.
  • WAN1 / Serial IP : 12.1.3.0/30 (mask 255.255.255.252)
  • WAN2 / Serial IP : 12.1.3.4/30 (mask 255.255.255.252)

  • LAN / Ethernet IP : 10.1.0.0/24 (mask 255.255.255.0)
  • Receiving Route : Default route + full route from ISP
  • Memory : Full route(recommend 512M), partial route
    (recommend 128-256M)
  • LAN : ISP (AS20) and Customer (AS10)

 

BGP sample configuration 2-1-1

 

 

[Traffic flow]

Outbound traffic on CPE perspective
Both circuits are sharing outbound traffic. It wouldn’t be exact 50/50% of traffic due to traffic will be routed per destination, but not per packets. However, if you want to share links by packet, you can apply command "ip load-sharing" on participant interfaces.
Inbound traffic  on CPE perspective
Same concept as outbound traffic flow

 

[CPE/Customer Cisco Router]

Current configuration:
!
version 12.x
!
hostname CPE
!
interface Loopback0
description to Loopback for BGP
ip address 1.1.1.1 255.255.255.255
no ip directed-broadcast
no ip mroute-cache
!
interface Ethernet0
description to Internal network
ip address 10.1.0.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
!
interface Serial0
description to ISP A – WAN 1
ip address 12.1.3.1 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
description to ISP A – WAN 2
ip address 12.1.3.5 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
router bgp 10
no auto-summary
network 10.1.0.0 mask 255.255.255.0
neighbor 3.3.3.3 remote-as 20
neighbor 3.3.3.3 version 4
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source loopback0
neighbor 3.3.3.3 prefix-list 1 out

!
ip classless
!
ip route 3.3.3.3 255.255.255.255 Serial0
ip route 3.3.3.3 255.255.255.255 Serial1
!
ip prefix-list 1 description to ISP
ip prefix-list 1 seq 5 permit 10.1.0.0/24 le 32
!
line con 0
line aux 0
line vty 0 4
login
!
end

 

[PE / ISP Cisco Router]

Current configuration:
!
version 12.x
!
hostname PE
!
interface Loopback0
description to Loopback for BGP
ip address 3.3.3.3 255.255.255.255
no ip directed-broadcast
no ip mroute-cache
!
interface Serial0
description to WAN 1
ip address 12.1.3.2 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
description to WAN 2
ip address 12.1.3.6 255.255.255.252
no ip mroute-cache
no ip directed-broadcast
no fair-queue
!
router bgp 20
no auto-summary
neighbor 1.1.1.1 remote-as 10
neighbor 1.1.1.1 version 4
neighbor
1.1.1.1 ebgp-multihop 2
neighbor
1.1.1.1 update-source loopback0
neighbor
1.1.1.1 default-originate <—to send a default route
!
ip classless
ip route 1.1.1.1 255.255.255.255 Serial0
ip route
1.1.1.1 255.255.255.255 Serial1
!
line con 0
line aux 0
line vty 0 4
login
!
end

[Verifing output]

CPE# show ip bgp neighbors 3.3.3.3 ad
BGP table version is 17, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.0.0/24      0.0.0.0                  0         32768 i

Total number of prefixes 1
CPE#
 


PE#show ip bgp nei 1.1.1.1 ro
BGP table version is 2, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.0.0/24      1.1.1.1                  0             0 10 i

Total number of prefixes 1
PE#

CPE#show ip bgp neighbors 3.3.3.3 ro
BGP table version is 17, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
              r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 0.0.0.0          3.3.3.3                  0             0 20 i

Total number of prefixes 1
CPE#

If you have any questions, feel free to send email us at [email protected]. If you are looking for professional grade service, you might want to try our "BGP experts service". What is "BGP Experts service"? Click "BGP Experts" from the top menu option. You will find out what the "BGP Experts" and what we are doing here for.

 

Author: Chris Yoon

IT professional