1-6-1. Cisco Single BGP with Multi-hop

BGP sample configuration 1-6-1

Cisco Single BGP with Multi-hop

   
  • ISPs : 1
  • WAN links : 1
  • CPE : 1
  • PE : 1
  • Device : Cisco router with LAN/WAN ports.
  • WAN / Serial IP : 12.1.3.0/30 (mask 255.255.255.252)
  • LAN / Ethernet IP : 10.1.0.0/24 (mask 255.255.255.0)
  • Receiving Route : Default route + full route from ISP
  • Memory : Full route(recommend 512M), partial route
    (recommend 128-256M)
  • LAN : ISP (AS20) and Customer (AS10)
  • Comments: If you have only single link with ISP, you don’t really need BGP protocol at all. Better to use just default route to save even bandwidth. Consult with professionals if really need it. This article is shown for educational purpose.

BGP sample configuration 1-6-1

[CPE/Customer Cisco Router]

Current configuration:
!
version 12.x
!
hostname CPE
!
interface Ethernet0
description to Internal network
ip address 10.1.0.1 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
!
interface Serial0
description to ISP
ip address 12.1.3.1 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Loopback 0
ip address 1.1.1.1 255.255.255.255 
no ip mroute-cache
no ip directed-broadcast
!
router bgp 10
no auto-summary
network 10.1.0.0 mask 255.255.255.0
neighbor 3.3.3.3 remote-as 20 <—- ISP’s ASN
neighbor 3.3.3.3 version 4
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source loopback0
!
ip classless
ip route 3.3.3.3 255.255.255.255 12.1.3.2
!
line con 0
line aux 0
line vty 0 4
login
!
end

[PE / ISP Cisco Router]

Current configuration:
!
version 12.x
!
hostname PE
!
!
interface Serial0
description to ISP
ip address 12.1.3.2 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Loopback 0
ip address 3.3.3.3 255.255.255.255 
no ip mroute-cache
no ip directed-broadcast
!
router bgp 20
neighbor 1.1.1.1 remote-as 10 <—- Other side’s ASN
neighbor 1.1.1.1 version 4
neighbor 1.1.1.1 default-originate <—- Sending default route to customer through BGP.
neighbor 1.1.1.1 ebgp-multihop 2
neighbor 1.1.1.1 update-source loopback0
neighbor 1.1.1.1 prefix-list 2 in
!
ip classless
!
ip route 1.1.1.1 255.255.255.255 12.1.3.1 
!
ip prefix-list 2 description from customer or peer
ip prefix-list 2 seq 5 permit 10.1.0.0/24 le 32 <—- Accepting smaller block than /24
!
line con 0
line aux 0
line vty 0 4
login
!
end

 [Verifing output]

CPE# show ip bgp neighbors 3.3.3.3 ad
BGP table version is 8, local router ID is x.x.x.x
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal
Origin codes: i – IGP, e – EGP, ? – incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.1.0.0/24 0.0.0.0 0 0 32768 ?
CPE#

PE#show ip bgp nei 1.1.1.1 ro
BBGP table version is 245, local router ID is x.x.x.x
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal
Origin codes: i – IGP, e – EGP, ? – incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.1.0.0/24 1.1.1.1 0 10 ?

Total number of prefixes 1

CPE#show ip bgp neighbors 3.3.3.3 ro
BGP table version is 10, local router ID is x.x.x.x
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal
Origin codes: i – IGP, e – EGP, ? – incomplete

Network NextHop Metric LocPrf Weight Path
*> 0.0.0.0 3.3.3.3 0 20 i

Total number of prefixes 1
CPE#

 If you have any questions, feel free to send email us at [email protected]. If you are looking for professional grade service, you might want to try our "BGP experts service". What is "BGP Experts service"? Click "BGP Experts" from the top menu option. You will find out what the "BGP Experts" and what we are doing here for.

Author: admin