BGP Community List http://showipbgp.com/bgp-tools/bgp-community-list.html Tue, 21 Nov 2017 11:43:49 +0000 Joomla! 1.5 - Open Source Content Management en-gb Time Warner Telecom AS4323 http://showipbgp.com/bgp-tools/bgp-community-list/100-time-warner-telecom-as4323.html http://showipbgp.com/bgp-tools/bgp-community-list/100-time-warner-telecom-as4323.html Attention This BGP Community string information might be outdated. Please contact Time Warner Telecom to get more recent one. This BGP communites is ONLY for the customer who has BGP with Time Warner Telecom. Also, Showipbgp.com is not maintaining this BGP Community string.

Time Warner Telecom AS4323 BGP Community String

Local Preference

BGP Community String Description
4323:80 Set Local Preference in AS4323 to 80
4323:100 Set Local Preference in AS4323 to 100
4323:120 Set Local Preference in AS4323 to 120
4323:187 Blackhole BGP Community -- Used only for /32 hosts
4323:555 Advertise to External Peers and Backbone Customers
4323:666 Keep with in TWTC backbone

AS prepend

BGP Community String Description
4323:1 Prepend AS4323 once
4323:2 Prepend AS4323 twice
4323:3 Prepend AS4323 three times


Network Operations E-mail: support@twtelecom.netThis e-mail address is being protected from spam bots, you need JavaScript enabled to view it
Network Operations Phone: 800-898-6473 (24/7)
Network Operations Phone (International): 1-303-542-6381 (24/7)
Peering E-mail: peering@twtelecom.netThis e-mail address is being protected from spam bots, you need JavaScript enabled to view it



Applying BGP Community string with sample configuration


1. Get the latest BGP community string from your ISP/upstream provider or check new.CiscoNET.com web site.

2. Pick the best BGP community string for your traffic shaping plan (mainly incoming traffic). Most of ISPs are providing BGP community string with local preference and AS prepending option. Cannot tell which one is better than the other. It will depend on your global traffic shaping plan.

3. Follow the below commands ( Cisco only )

The below Sample configuration will tag the 10.0.0.0/24 route with [ISP AS]:120 or [ISP AS]:3 and will not tag any other routes.


router#config t
router(config)#ip bgp-community new-format
router(config)#access-list 10 permit 10.0.0.0 0.0.0.255
router(config)#access-list 10 deny any

router(config)#route-map [to-ISP] permit 10
router(config-route-map)#match ip address 10
router(config-route-map)#set community [ISP AS]:120 <---- using Local Preference

or

router(config-route-map)#set community [ISP AS]:3 <------- using AS prepending
router(config-route-map)#route-map [to-ISP] permit 20
router(config-
route-map)#exit

router(config)#router bgp [xxxx] <------------------------------- xxxx = customer's ASN
router(config-router)#neighbor x.x.x.x send-community
router(config-router)#neighbor x.x.x.x route-map [to-ISP] out
router(config-router)#exit
router(config)#exit
router#copy running-config startup-config


4. And then, go to www.CiscoNET.com and pick one of route server on the map to see your announcement. If you are using AS prepending option, you will see your AS prepends on route servers. Sometime you might not see your route with particular ISP path.
In most of case it might not be any routing problem, just the route path was dropped at somewhere by BGP best path selection scheme. Try Oregon route server, if you can see your route. The Oregon route server is providing many possible and available paths between BGP speakers and neighbors.
If you don't see your route on there? check other route servers and also check your
BGP configuration. You might need to contact your upstream provider to check what they are learning BGP route from you..

 



]]>
chris.yoon@wirethink.com (Showipbgp) BGP Community List Wed, 16 Apr 2008 14:16:51 +0000
XO Communications AS2828 http://showipbgp.com/bgp-tools/bgp-community-list/99-xo-communications-as2828.html http://showipbgp.com/bgp-tools/bgp-community-list/99-xo-communications-as2828.html

XO Communications  AS2828 BGP Communities Controls

Attention

This BGP Community string information might be outdated. Please contact XO Communications AS2828 to get more recent one. This BGP communites is ONLY for the customer who has BGP with XO Communications AS2828. Showipbgp.com is not maintaining this BGP Community string.

 

Local Preference BGP Community String
 
The general XO routing policy is to prefer our customer's BGP and static routes over "external"
(non-customer) BGP routes.
For our BGP customers, XO has implemented a powerful, flexible system whereby we allow our customers to control – via predefined BGP communities – the XO treatment of their announcements. These BGP communities control XO local-preference (local-pref) of customer -announced routes within our network. The most powerful attribute is local-preference.
In BGP, the higher the local-pref, the more preferred the route on the network. This affects XO backbone route selection only, and not the route selection made by XO peers and customers, because localpreference is non-transitive. This means it does not get passed beyond the XO network. The customer has a range of six local-preferences to which they can set their routes.
The following table details the local-prefs, including the actual value, the BGP community accepted from the customer to set the local-pref, and a description of what that local-pref will do in the network.
 

 
BGP Community String Local Prep Description
2828:1507 70 Lower (less preferred) than all
other routes on network, incl all
public & private peer routes
2828:1508 80 Same as public and private
peers.
2828:1509 90
 
none 100 Default for all customer routes,
BGP and static
2828:1510 100 Explicitly set customer BGP
announcements to 100
2828:1511 110 Higher (more preferred) than all
default customer BGP and static
routes
2828:1512 120 Highest (most preferred) localpref
that a customer can specify


AS-Path Controls

The next attribute that customers can use to control their routing is via AS path length.
The most common use of AS-path prepending is in a direct peering route-map on the customer end where they can prepend their own AS to their routes as they announce the routes to AS2828. XO also accepts BGP communities that prepend AS 2828 either one time or three times to the route as it leaves the 2828 network.
 
Currently, there are three general groups on which the customer can set 2828 prepends:
 

 
BGP Communities that Change Customer Announcements to Certain Peers atAS2828 Border

 
Provider
Name or
Group
"Don't
Advertise to"
BGP Community
"Prepend
Once"
BGP Community
"Prepend
Twice"
BGP Community
“Prepend
Thrice”
BGP Community
All
Peers
2828:1000 2828:1100
 
2828:1200
 
2828:1300
 
Sprint 2828:1003 2828:1103
 
2828:1203
 
2828:1303
 
Cable &
Wireless
2828:1004 2828:1104 2828:1204
 
2828:1304
 
Verizon 2828:1006 2828:1106
 
2828:1206
 
2828:1306
 
Level3 2828:1007 2828:1107
 
2828:1207
 
2828:1307
ATT 2828:1008 2828:1108
 
2828:1208
 
2828:1308
 


 
Origin Attribute
Another standard option for customers to control XO treatment of their advertisements involves the use of the origin attribute.
XO does not alter origin code on routes customers send us. Routes set with the IGP origin code are more preferred than routes tagged with the origin EGP code, which are more preferred than origin-Incomplete routes.
 

 
DoS Discard Community
XO provides a mechanism allowing customers to trigger the XO backbone to discard all traffic entering the XO network from external sources destined for any routes specifically announced by a BGP customer with a special BGP community.
 

 
XO customers may announce this route to XO to mitigate the over utilization of their uplink or general harm caused by such an attack until they open a ticket (if required) and XO technicians help stop the attack.
 

 
Other Accepted BGP Communities
 
BGP Community String
 
Description
 
2828:1650
 
Used to blackhole traffic
 
no-export/no-advertise
 
Don’t announce outside of XO
 

 

MED Controls

Another standard option for customers to control XO treatment of their advertisements involves the use of the MED attribute. The lower the MED attribute set on a route, the more preferred the route. XO currently accepts MED from its customers.
For more details on (Cisco) BGP path selection and attributes, see Cisco's Web site.


 
Sample Customer Configurations
The following configurations are samples, provided for educational purposes only.
Customers managing their own CPE, running BGP to XO Communications, should understand the abilities of the protocol, and manage their router based on their own needs. Inbound controls could be stricter and many other variations could place different configuration requirements.
The examples below show simple and complex configurations, but they could become more complex depending on the customer’s needs.
For further guidance, see the Cisco Web site.


 

Applying BGP Community string with sample configuration

1. Get the latest BGP community string from your ISP/upstream provider or check new.CiscoNET.com web site.

2. Pick the best BGP community string for your traffic shaping plan (mainly incoming traffic).
Most of ISPs are providing community string with local preference and AS prepending
option. Cannot tell which one is better than the other. It will depend on your global traffic shaping plan.

3. Follow the below commands ( Cisco only )

The below Sample configuration will tag the 10.0.0.0/24 route with [ISP AS]:120 or [ISP AS]:3 and will not tag any other routes.
 

router#config t
router(config)#ip bgp-community new-format
router(config)#access-list 10 permit 10.0.0.0 0.0.0.255
router(config)#access-list 10 deny any

router(config)#route-map [to-ISP] permit 10
router(config-route-map)#match ip address 10
router(config-route-map)#set community [ISP AS]:120 <---- using Local Preference

or

router(config-route-map)#set community [ISP AS]:3 <------- using AS prepending
router(config-route-map)#route-map [to-ISP] permit 20
router(config-route-map)#exit

router(config)#router bgp [xxxx] <------------------------------- xxxx = customer's ASN
router(config-router)#neighbor x.x.x.x send-community
router(config-router)#neighbor x.x.x.x route-map [to-ISP] out
router(config-router)#exit
router(config)#exit
router#copy running-config startup-config

4. And then, go to www.CiscoNET.com and pick one of route server on the map to see your announcement. If you are using AS prepending option, you will see your AS prepends on route servers. Sometime you might not see your route with particular ISP path.
In most of case it might not be any routing problem, just the route path was dropped at somewhere by BGP best path selection scheme. Try Oregon route server, if you can see your route. The Oregon route server is providing many possible and available paths between BGP speakers and neighbors.
If you don't see your route on there? check other route servers and also check your
BGP configuration. You might need to contact your upstream provider to check what they are learning BGP route from you.

 

* We do NOT support or maintain any BGP community string
** Contact ISP to get more detail information


]]>
chris.yoon@wirethink.com (Showipbgp) BGP Community List Wed, 16 Apr 2008 14:14:07 +0000
NTT/Verio AS2914 http://showipbgp.com/bgp-tools/bgp-community-list/98-nttverio-as2914.html http://showipbgp.com/bgp-tools/bgp-community-list/98-nttverio-as2914.html

NTT/Verio AS2914 BGP Community String

Attention

This BGP Community string information might be outdated. Please contact NTT/Verio AS2914 to get more recent one. This BGP communites is ONLY for the customer who has BGP with NTT/Verio AS2914. Also, Showipbgp.com is not maintaining this BGP Community string.


 
Verio BGP customers may choose to affect our local preference on their routes by marking their routes with the following BGP communities:
 

 
BGP Community String Local Prep
Description
(default) 120 Customer
2914:490 120 Customer default
2914:480 110 Customer backup
2914:470 100 Peer
2914:460 98 Peer backup
2914:450 96 Customer fallback


 
Verio BGP customers may choose to prepend to all Verio peers with the following BGP communities
 

 
BGP Community String Prepend AS Description
2914:429 -
 
Do not advertise to any peer
2914:423 2914 2914 2914 Prepends o/b to peer 3x
2914:422 2914 2914 Prepends o/b to peer 2x
2914:421 2914 Prepends o/b to peer 1x


 
Verio BGP customers may choose to prepend to all other Verio BGP customers with the following BGP communities
 


 
BGP Community String Prepend AS Description
2914:413 2914 2914 2914 Prepends o/b to customer 3x
2914:412 2914 2914 Prepends o/b to customer 2x
2914:411 2914 Prepends o/b to customer 1x


 
Verio BGP customers may choose to prepend to selected tier 1 peers with the following BGP communities, where nnn is the tier 1 peer's ASN.
 

 
BGP Community String Prepend AS Description
65500:nnn - Do not announce to tier 1 peer
65501:nnn nnn Prepend o/b to tier 1 peer 1x
65502:nnn nnn nnn Prepend o/b to tier 1 peer 2x
65503:nnn nnn nnn nnn Prepend o/b to tier 1 peer 3x


 
Verio sends routes to customers marked with the following communities
 

 

BGP Community String Interpretation
2914:410 Verio and customer routes
2914:420 Peer routes
2914:20-- North American country origins
2914:2000 US
2914:22-- European country origins
2914:2201 uk
2914:2202 de
2914:2203 nl
2914:2204 fr
2914:2205 es (Spain)
2914:24-- Asian country origins
2914:2401 jp
2914:2402 au
2914:2403 hk
2914:2404 tw
2914:2405 kr
2914:2406 sg
2914:2407 my
2914:3--- world region origins
2914:3000 North America
2914:3200 Europe
2914:3400 Asia

 

BGP IPv4 peer filter policy

inbound:

    • Verio accepts only those prefixes of length /24 and shorter from traditional class A, B, and C space.
    • Verio uses max-prefix filters at most public exchanges. The max-prefix filter is set to 110% of the greater of the following values:
      • number of prefixes announced in the last 24 hours
      • number of prefixes registered in the routing registries under the peer's as-set if this number is less than 5000.

outbound:

    • Verio will accept any properly registered prefix from our customers but will announce only /24 and shorter prefixes to our peers.
    • All Verio's announcements are registered in one of the routing registries and included under as-set AS-VERIO.

Verio reserves the right to modify this policy without prior notice.


 

BGP IPv6 peer filter policy

The following is Verio's filtering policy with its peers:

inbound:

      • Verio accepts /19 through /32, and /35 from 2001::/16 (global unicast allocations)
      • Verio accepts /19 through /32 from 2003::/16 (RIPE allocations)
      • Verio accepts /24 from 3ffe::/18, /32 from 3ffe:4000::/18, and /28 from 3ffe:8000::/20 (6bone allocations; until 6/6/2006 per rfc3701)
      • Verio accepts 2002::/16 (6to4 prefix)

outbound:

    • Verio will announce /48 and shorter prefixes to our peers.

Verio reserves the right to modify this policy without prior notice.


 

Verio Routing Registry

Verio requires that all customer BGP routes be registered in either Verio's routing registry, or one of the Internet routing registries mirrored by Verio. The current list of mirrored registries is:
    altdb apnic arcstar bell enterzone gt host level3 radb rgnet ripe savvis sinet
Verio customers are welcome to register their objects in our registry. Look here for more info on our Registry.
 


 

Route Dampening

Route dampening is a BGP feature designed to minimize the propagation of flapping routes across an internetwork. A route is considered to be flapping when it is repeatedly available, then unavailable, then available, then unavailable, and so on.

 

The Route Dampening Process:

 

The route dampening feature minimizes the flapping problem as follows.

Suppose a route in network A flaps. A route that is flapping receives a penalty of 1000 for each flap and moves it to "history" state. When the route flaps so often that the penalty exceeds a configurable suppress limit, the router stops advertising the route, regardless of how many times it flaps. Thus, the route is dampened.

The accumulated penalty is decremented by the half-life time. When the accumulated penalty is less than the reuse limit, the dampening information for the route is removed and the route is advertised again.

Verio sets different dampening parameters for different sizes of address blocks across the network.

a) For /24 and longer prefixes: max=min outage 60 minutes half-life = 30 Maximum suppress limit = 60 Reuse limit = 820 Suppress limit = 3000

b) for /22 and /23 prefixes: max outage 45 minutes but potential for less because of shorter half life value - minimum of 30 minutes outage Half-life = 15 Maximum suppress limit = 45 Reuse limit = 750 Suppress limit = 3000

c) all else prefixes: max outage 30 minutes min outage 10 minutes Half-life = 10 Maximum suppress limit = 30 Reuse limit = 1500 Suppress limit = 3000

 

Understanding Route Dampening Terms:

The following terms are used when describing route dampening:

    • Flap - A route is available, then unavailable, or vice versa.

       

    • History state - After a route flaps once, it is assigned a penalty and put into "history state," meaning the router does not have the best path, based on historical information.

       

    • Penalty - Each time a route flaps, the router configured for route dampening in another AS assigns the route a penalty of 1000. Penalties are cumulative. The penalty for the route is stored in the BGP routing table until the penalty exceeds the suppress limit. At that point, the route state changes from "history" to "damp."

       

    • Damp state - In this state, the route has flapped so often that the router will not advertise this route to BGP neighbors.

       

    • Suppress limit - A route is suppressed when its penalty exceeds this limit. The default value is 2000.

       

    • Half-life - Once the route has been assigned a penalty, the penalty is decreased by half after the half-life period (which is 15 minutes by default). The process of reducing the penalty happens every 5 seconds.

       

    • Reuse limit - As the penalty for a flapping route decreases and falls below this reuse limit, the route is unsuppressed. That is, the route is added back to the BGP table and once again used for forwarding. The default reuse limit is 750. The process of unsuppressing routes occurs at 10-second increments. Every 10 seconds, the router finds out which routes are now unsuppressed and advertises them to the world.

       

    • Maximum suppress limit - This value is the maximum amount of time a route can be suppressed. The default value is 4 times the half-life.

The routes external to an AS learned via IBGP are not dampened. This policy prevent the IBGP peers from having a higher penalty for routes external to the AS.

 

 

 

 

Applying BGP Community string with sample configuration
 

1. Get the latest BGP community string from your ISP/upstream provider or check new.CiscoNET.com web site.

2. Pick the best BGP community string for your traffic shaping plan (mainly incoming traffic).
Most of ISPs are providing community string with local preference and AS prepending
option. Cannot tell which one is better than the other. It will depend on your global traffic shaping plan.

3. Follow the below commands ( Cisco only )

The below Sample configuration will tag the 10.0.0.0/24 route with [ISP AS]:120 or [ISP AS]:3 and will not tag any other routes.
 

router#config t
router(config)#ip bgp-community new-format
router(config)#access-list 10 permit 10.0.0.0 0.0.0.255
router(config)#access-list 10 deny any

router(config)#route-map [to-ISP] permit 10
router(config-route-map)#match ip address 10
router(config-route-map)#set community [ISP AS]:120 <---- using Local Preference

or

router(config-route-map)#set community [ISP AS]:3 <------- using AS prepending
router(config-route-map)#route-map [to-ISP] permit 20
router(config-route-map)#exit

router(config)#router bgp [xxxx] <------------------------------- xxxx = customer's ASN
router(config-router)#neighbor x.x.x.x send-community
router(config-router)#neighbor x.x.x.x route-map [to-ISP] out
router(config-router)#exit
router(config)#exit
router#copy running-config startup-config

 

4. And then, go to www.CiscoNET.com and pick one of route server on the map to see your announcement. If you are using AS prepending option, you will see your AS prepends on route servers. Sometime you might not see your route with particular ISP path.
In most of case it might not be any routing problem, just the route path was dropped at somewhere by BGP best path selection scheme. Try Oregon route server, if you can see your route. The Oregon route server is providing many possible and available paths between BGP speakers and neighbors.
If you don't see your route on there? check other route servers and also check your
BGP configuration. You might need to contact your upstream provider to check what they are learning BGP route from you.

 

 

* We do NOT support or maintain any BGP community string
** Contact ISP to get more detail information


]]>
chris.yoon@wirethink.com (ShowIPBGP) BGP Community List Wed, 16 Apr 2008 14:13:07 +0000
Sunrise/TDC Switzerland AS6730 http://showipbgp.com/bgp-tools/bgp-community-list/97-sunrisetdc-switzerland-as6730.html http://showipbgp.com/bgp-tools/bgp-community-list/97-sunrisetdc-switzerland-as6730.html

Sunrise/TDC Switzerland AG's AS6730 BGP communities support

Attention

This BGP Community string information might be outdated. Please contact Sunrise/TDC Switzerland AS6730 to get more recent one. This BGP communites is ONLY for the customer who has BGP with Sunrise/TDC Switzerland AS6730. Also, Showipbgp.com is not maintaining this BGP Community string.

 

The following BGP community strings may be used to influence our routing policies. In all cases, the format of the string should be 6730:xxxx, where xxxx is defined in the table below

Do not Prepend

Send To peer: +1 +2 +3
 

1010 European Upstreams eu 1110 1210 1310

1011 US Upstreams uu 1111 1211 1311
1012 Level 3 (AS3356) uu 1112 1212 1312
1013 (ex AS15412) uu 1113 1213 1313
1014 France T. (AS5511) eu 1114 1214 1314
1015 (ex AS7018) eu 1115 1215 1315
1016 (ex AS1239) eu 1116 1216 1316
1019 Concert (AS5400) eu 1119 1219 1319
1021 Swiss private peers 1121 1221 1321
1022 TDC * 1122 1222 1322
1030 European Peerings ep 1130 1230 1330
1031 US Peerings up 1131 1231 1331
1032 LINX Peerings ep 1132 1232 1332
1033 AMS-IX Peerings ep 1133 1233 1333
1034 DE-CIX Peerings ep 1134 1234 1334
1035 SwissIX Peerings ep 1135 1235 1335
1036 VIX Peerings ep 1136 1236 1336
1037 SFINX Peerings ep 1137 1237 1337
1038 CIXP Peerings ep 1138 1238 1338
1039 MIX Peerings ep 1139 1239 1339
1040 (ex PAIX-PA) up 1140 1240 1340
1043 Int. private peers 1143 1243 1343
1044 TIX Peerings ep 1144 1244 1344
1045 NYIIX Peerings up 1145 1245 1345
1046 NOTA Peerings up 1146 1246 1346
1047 EQA Peerings up 1147 1247 1347
 


In addition, it is possible to affect the LOCAL-PREF settings within the sunrise network. Use these with care, as the results can be serious.
 

default customer route local pref 100

 
6730:0001 set local pref to 95
6730:0002 set local pref to 94
 
default swiss peer route local pref 90
 
6730:0003 set local pref to 85
6730:0004 set local pref to 84
 
default international peer route local pref 80
 
6730:0005 set local pref to 75
6730:0006 set local pref to 74
 
default upstream route local pref 70
 
6730:0007 set local pref to 65
6730:0008 set local pref to 64
 


 

To implement these BGP communities on your link to sunrise, use a config similar to the following
 
neighbor x.x.x.x remote-as 6730
neighbor x.x.x.x description sunrise
neighbor x.x.x.x send-community
neighbor x.x.x.x route-map to_sunrise out
 

route-map to_sunrise permit 10
set community 6730:aaaa
 


 

The following BGP community strings may be used to determine the source of a route

6730:6000 Global Transit Customer

6730:6001 Swiss Transit Customer
6730:6100 Upstream
6730:6201 National Peer
6730:6232 LINX
6730:6233 AMS-IX
6730:6234 DE-CIX
6730:6235 SwissIX
6730:6236 VIX
6730:6237 SFINX
6730:6238 CIXP
6730:6239 MIX
6730:6243 sunrise Partner
6730:6244 TIX
6730:6245 NYIIX
6730:6246 NOTA (Miami)
6730:6247 EQA (Ashburn)
 


 

'Trampoline' BGP communities
 

Concert (AS5400)

 
6730:7004 5400:1000
 
Do not announce to US upstreams/peers
 
6730:7005 5400:1100
 
Do not announce to european peers

homepage: www.sunrise.net


 

Applying BGP Community string with sample configuration

1. Get the latest BGP community string from your ISP/upstream provider or check new.CiscoNET.com web site.

2. Pick the best BGP community string for your traffic shaping plan (mainly incoming traffic). Most of ISPs are providing BGP community string with local preference and AS prepending option. Cannot tell which one is better than the other. It will depend on your global traffic shaping plan.

3. Follow the below commands ( Cisco only )

The below Sample configuration will tag the 10.0.0.0/24 route with [ISP AS]:120 or [ISP AS]:3 and will not tag any other routes.

router#config t
router(config)#ip bgp-community new-format
router(config)#access-list 10 permit 10.0.0.0 0.0.0.255
router(config)#access-list 10 deny any

router(config)#route-map [to-ISP] permit 10
router(config-route-map)#match ip address 10
router(config-route-map)#set community [ISP AS]:120 <---- using Local Preference

or

router(config-route-map)#set community [ISP AS]:3 <------- using AS prepending
router(config-route-map)#route-map [to-ISP] permit 20
router(config-route-map)#exit

router(config)#router bgp [xxxx] <------------------------------- xxxx = customer's ASN
router(config-router)#neighbor x.x.x.x send-community
router(config-router)#neighbor x.x.x.x route-map [to-ISP] out
router(config-router)#exit
router(config)#exit
router#copy running-config startup-config
 

4. And then, go to www.CiscoNET.com and pick one of route server on the map to see your announcement. If you are using AS prepending option, you will see your AS prepends on route servers. Sometime you might not see your route with particular ISP path.
In most of case it might not be any routing problem, just the route path was dropped at somewhere by BGP best path selection scheme. Try Oregon route server, if you can see your route. The Oregon route server is providing many possible and available paths between BGP speakers and neighbors.
If you don't see your route on there? check other route servers and also check your
BGP configuration. You might need to contact your upstream provider to check what they are learning BGP route from you.

 
 

 

* We do NOT support or maintain any BGP community string
** Contact ISP to get more detail information


]]>
chris.yoon@wirethink.com (ShowIPBGP) BGP Community List Wed, 16 Apr 2008 14:11:55 +0000
Sprint AS1239 http://showipbgp.com/bgp-tools/bgp-community-list/96-sprint-as1239.html http://showipbgp.com/bgp-tools/bgp-community-list/96-sprint-as1239.html

Sprint AS1239 BGP Community Strings

Attention

This BGP Community string information might be outdated. Please contact Sprint AS1239 to get more recent one. This BGP communites is ONLY for the customer who has BGP with Sprint AS1239.  Showipbgp.com is not maintaining this BGP Community string.


BGP can be set up for your connection if you are dual homed to Sprint, or multi-homed to another provider. This document is intended to provide enough information for you to evaluate your options in setting up your BGP session.

 

BASIC REQUIREMENTS

  1. You must be multi-homed to run BGP
  2. You must have an AS number from ARIN, RIPE or APNIC
  3. You must have IOS 10.3 or higher to run BGP and we do not turn up new BGP sessions with anything less than version 10.3
  4. You must be capable of configuring your BGP session. Sprint does not provide assistance in configuring customer routers for BGP.
  5. You should NOT configure unfiltered redistribution from your interior routing protocol into BGP.
  6. Explicit distribute-list or network statements should be used to prevent injections of invalid routes into global tables.
  7. You should NOT redistribe routes from BGP into your interior routing protocols, as it corrupts as-path information.
  8. You should configure filters that prevent leakage of routing information from your other service providers to us and vice versa. Filters should be inclusive, rather than exclusive i.e. they should list customer ASs instead of excluding other provider's ASs).
  9. IP blocks for several specific routes should be aggregated into larger routes as much as possible.
  10. Networks listed in configuration should be sane (i.e. no networks assigned to other customers, subnets should never be announced outside, etc).


 

RESTRICTIONS

  1. Sprint will not run EBGP Multi-hop except for load balancing purposes between the loopback addresses of the Customer and Sprint routers that share multiple serial connections.
  2. Sprint reserves the right to aggregate any announcement for a network smaller than /19 when advertising to external peers such as AT&T, UUnet etc.
  3. Customers will not be permitted to use '*' wildcards in their requested route filters.


WHAT TO EXPECT

NEW CIRCUIT INSTALLATION:

At the time of circuit installation, inform the installation engineer that you want to configure BGP, and be prepared to complete the BGP request form.

CONVERSION FROM STATIC ROUTING:

  • Complete the BGP request form.
  • Sprint will configure their side of the line and copy the customer with the BGP configuration changes. (Your static routes will not be removed at this time)
  • Once Sprint is finished configuring its portion, you are responsible for initiating or clearing the BGP session.
  • Once you are satisfied that the session is up and running, you should notify the Sprintlink Support Team to remove your old static routes. Please use the Comments section of the BGP request form to contact the Sprintlink Support Team.

MODIFICATIONS:

Any time you need to modify your BGP filter, you must complete the BGP request form. Sprint will take action on all requests within 36 hours of receipt of the request. Please use the Comments section of the BGP request form for any questions that you may have.
 

 

WHAT YOU CAN CONTROL

AS-PATH PREPENDS

Sprint allows customers to use AS-path prepending to adjust route preference on the network. Such prepending will be received and passed on properly without notifiying Sprint of your change in announcments.

Additionally, Sprint will prepend AS1239 to eBGP sessions with certain autonomous systems depending on a received BGP community. Currently, the following ASes are supported: 1668, 209, 2914, 3300, 3356, 3549, 3561, 4635, 701, 7018, 702 and 8220.



 
BGP Community String
Resulting AS Path to ASXXX
65000:XXX
Do not advertise to ASXXX
65001:XXX
1239 (default) ...
65002:XXX
1239 1239 ...
65003:XXX
1239 1239 1239 ...
65004:XXX
1239 1239 1239 1239 ...

 
BGP Community String
Resulting AS Path to ASXXX in Asia
65070:XXX
Do not advertise to ASXXX
65071:XXX
1239 (default) ...
65072:XXX
1239 1239 ...
65073:XXX
1239 1239 1239 ...
65074:XXX
1239 1239 1239 1239 ...

 
BGP Community String
Resulting AS Path to ASXXX in Europe
65050:XXX
Do not advertise to ASXXX
65051:XXX
1239 (default) ...
65052:XXX
1239 1239 ...
65053:XXX
1239 1239 1239 ...
65054:XXX
1239 1239 1239 1239 ...

 
BGP Community String
Resulting AS Path to ASXXX in North America
65010:XXX
Do not advertise to ASXXX
65011:XXX
1239 (default) ...
65012:XXX
1239 1239 ...
65013:XXX
1239 1239 1239 ...
65014:XXX
1239 1239 1239 1239 ...

BGP Community String
Resulting AS Path to all supported ASes
65000:0
Do not advertise
65001:0
1239 (default) ...
65002:0
1239 1239 ...
65003:0
1239 1239 1239 ...
65004:0
1239 1239 1239 1239 ...

 
BGP Community String
Resulting AS Path to all supported ASes in Asia
65070:0
Do not advertise
65071:0
1239 (default) ...
65072:0
1239 1239 ...
65073:0
1239 1239 1239 ...
65074:0
1239 1239 1239 1239 ...

 
BGP Community String
Resulting AS Path to all supported ASes in Europe
65050:0
Do not advertise
65051:0
1239 (default) ...
65052:0
1239 1239 ...
65053:0
1239 1239 1239 ...
65054:0
1239 1239 1239 1239 ...

 
BGP Community String
Resulting AS Path to all supported ASes
in North America
65010:0
Do not advertise
65011:0
1239 (default) ...
65012:0
1239 1239 ...
65013:0
1239 1239 1239 ...
65014:0
1239 1239 1239 1239 ...


 

LOCAL PREFERENCE

You can control the local preference for your announcements on the Sprint router using a BGP community string which you may pass to Sprint in your BGP session. The following table lists the BGP community strings and the corresponding local preference that Sprint will set in the network. Remember that BGP community strings are not exported by default, so be sure to add whatever export command is necessary for your router.



 
BGP Community String
Resulting Local Pref
1239:70 70
1239:80 80
1239:90 90
1239:100 100
1239:110 110
 

 

MED (Multi Exit Discriminator)

Sprint accepts MEDs from all customers to adjust route preference on the network.

NO-EXPORT

Sprint will accept the well-known community "no-export".

TRANSIT TO NON-TRANSIT

Sprint allows transit customers to tag routes to be non-transit by sending BGP community String "1239:600". A non-transit route will not be advertised as a Sprint customer route. This route will still be advertised to customers who receive the full Internet routing table, but will not be advertised to eBGP peers who only wish to receive Sprint customer routes.


 

REMOTE TRIGGERED BLACKHOLE

Sprint now offers the ability for customers running BGP to remotely manage a null route for their hosts in the event of a DDoS attack. This prevents the customer circuit from being overwhelmed with attack traffic and gives customers the flexibility to make the changes without having to contact Sprint. This capability requires additional configuration restrictions.
  1. Customer must be using a prefix style filter with Sprint. Wildcards will not be allowed in the filter.
  2. Customer must have MD5 passwords enabled on the BGP session(s) with Sprint.
  3. The route will only be nullrouted on the directly peering router. If the customer has multiple connections with Sprint, the tagged prefix must be announced though each peering session.
  4. This policy is subject to change and the capability may be globally revoked if operational issues are found that affect the stability of Sprint's network.
  5. Sprint is not responsible for any misconfiguration on the customer equipment which results in unintended traffic loss.
Once the request for RTB service has been reviewed, a Sprint technician will contact the customer to arrange the password setup. After setup, the customer can trigger a blackhole by sending an authorized route between /30 and /32 with the community 1239:66 to Sprint.
 

 


 

 

Applying BGP Community string with sample configuration

1. Get the latest BGP community string from your ISP/upstream provider or check new.CiscoNET.com web site.

2. Pick the best BGP community string for your traffic shaping plan (mainly incoming traffic).
Most of ISPs are providing community string with local preference and AS prepending
option. Cannot tell which one is better than the other. It will depend on your global traffic shaping plan.

3. Follow the below commands ( Cisco only )

The below Sample configuration will tag the 10.0.0.0/24 route with [ISP AS]:120 or [ISP AS]:3 and will not tag any other routes.
 

router#config t
router(config)#ip bgp-community new-format
router(config)#access-list 10 permit 10.0.0.0 0.0.0.255
router(config)#access-list 10 deny any

router(config)#route-map [to-ISP] permit 10
router(config-route-map)#match ip address 10
router(config-route-map)#set community [ISP AS]:120 <---- using Local Preference

or

router(config-route-map)#set community [ISP AS]:3 <------- using AS prepending
router(config-route-map)#route-map [to-ISP] permit 20
router(config-route-map)#exit

router(config)#router bgp [xxxx] <------------------------------- xxxx = customer's ASN
router(config-router)#neighbor x.x.x.x send-community
router(config-router)#neighbor x.x.x.x route-map [to-ISP] out
router(config-router)#exit
router(config)#exit
router#copy running-config startup-config


 

4. And then, go to www.CiscoNET.com and pick one of route server on the map to see your announcement. If you are using AS prepending option, you will see your AS prepends on route servers. Sometime you might not see your route with particular ISP path.
In most of case it might not be any routing problem, just the route path was dropped at somewhere by BGP best path selection scheme. Try Oregon route server, if you can see your route. The Oregon route server is providing many possible and available paths between BGP speakers and neighbors.
If you don't see your route on there? check other route servers and also check your
BGP configuration. You might need to contact your upstream provider to check what they are learning BGP route from you.

 

 

* We do NOT support or maintain any BGP community string
** Contact ISP to get more detail information


]]>
chris.yoon@wirethink.com (ShowIPBGP) BGP Community List Wed, 16 Apr 2008 14:11:00 +0000
Savvis Communications AS3561 http://showipbgp.com/bgp-tools/bgp-community-list/95-savvis-communications-as3561.html http://showipbgp.com/bgp-tools/bgp-community-list/95-savvis-communications-as3561.html

Savvis Communications AS3561 BGP Community Strings

Attention

This BGP Community string information might be outdated. Please contact Savvis Communications AS3561 to get more recent one. This BGP communites is ONLY for the customer who has BGP with Savvis Communications AS3561. Showipbgp.com is not maintaining this BGP Community string.



1. SAVVIS Received BGP Community Attribute Values (BGP community String)

SAVVIS Prepend/Suppression BGP Community Attribute Values (3561:30PPN)

SAVVIS allows customers to control certain traffic flows off-net with the implementation of BGP community attribute values that prepend route/prefix paths with additional AS hops. These BGP community attribute values, which the customer applies, affects the way SAVVIS peers choose the degree of preference of a given prefix/route, because the number of AS hops within the route-path has been lengthened.

The format for the second component of customer route BGP community number (after 3561:) is set at five digits. This fixed length allows regular expressions to be used in applying a defined number of prepends to a given route/prefix path. This format is 3561:30PPN, where the fields are coded in the following way. (Note: The first 2 digits of the second component are always "30" then followed by variables of the "PP" and "N" variables which are defined in the following tables.)

The "PP" variable cross references peers of SAVVIS, defined in the following table. (Note, this will always be a two digit value.)

 
PP Code Peer Name Peer AS Number
00 All Peers -
01 SBC AS7132
02 Sprint AS1239
03 Tiscali AS3257
04 Qwest AS209
06 Verio/NTT AS2914
07 Level3 AS3356
08 GlobalCrossing AS3549
09 FranceTelecom AS5511
10 WilliamsCommunicationsGroup AS7911
11 DeutscheTelekomAG AS3320
12 XOCommunications AS2828
13 AboveNet/MFN AS6461
14 UUNet AS701
15 AT&T AS7018
18 Cogent AS174
21 ATDN AS1668
41 Colt AS8220
43 Infonet AS3300
44 UUNet-EU AS702
46 Telia AS1299


The "N" variable cross references the number of prepends, defined in the following table. Please note, the only valid "N" value for all peers (PP code 00) is 0 (Do not export).

N Values

"N" Value Meaning

0 Do not export
1 Prepend once
2 Prepend twice
3 Prepend three times
9 Announce-only


Examples:

3561:30030 Do not export this route to PSINet (AS174)
3561:30142 Prepend this route twice, to UUNet (AS701)
3561:30159 Announce this route only to AT&T (AS7018)
SAVVIS Blackhole BGP Community Attribute Values (3561:666)

For customers that have a host or block under a DDoS, the affected host/block can be advertised to AS3561 with BGP community string 3561:666. This will cause all traffic to that host to be black-holed at the core of the AS3561 network. This action will trigger emails sent to the appropriate security and operations groups for notification purposes.

After advertising the prefix with 3561:666, the customer should open a priority one incident report with Client Services:

SAVVIS Support Center (SSC)

Phone: 888-638-6771

email: ssc@savvis.netssc@savvis.netThis e-mail address is being protected from spam bots, you need JavaScript enabled to view it

Once the attack has been mitigated, the customer will be responsible for removing the prefix from being advertised.

SAVVIS will not be held responsible for customers who errantly advertise prefixes with the blackhole BGP community string.
 

SAVVIS Received BGP Community Attribute Values

Value: 3561:70
Definition:
Sets local preference value within AS3561 to "70".

Value: 3561:80
Definition:
Sets local preference value within AS3561 to "80".

Value: 3561:90
Definition:
Sets local preference value within AS3561 to "90".

Value: 3561:no-export or 3561:no-advertise
Definition:
Will prevent the network/prefix tagged with this (either) BGP community attribute from being announced outside AS3561. Note, this will prevent the route from being propagated to SAVVIS eBGP customers receiving a routing table.



2. SAVVIS Announced BGP Community Attribute Values

Formerly, only two SAVVIS BGP community attribute values were announced to users upon request: 3561:900 (customer routes) and 3561:999 (peer routes). These have been replaced by a new BGP community string implementation.

The new implementation allows for a 5 digit string, following the "3561:" notation. Each bit/digit has a pertinent value and meaning represented in the following tables (3561:xxxxx)

This was facilitated to provide the following routing information to customers receiving a routing table from SAVVIS via eBGP routing.

Identification of route source by a. Customer or peer b. Region - Predefined by SAVVIS - Based upon physical connection point c. Country - Predefined by SAVVIS - Based upon physical connection point

The format for the second component of customer route BGP community number (after 3561:) is set at five digits. This fixed length allows regular expressions to be used in routing policy statements to select subsets of customer routes. This format is 3561:SRCCC where the fields are coded in the following way.

"S" refers to 'source' of the route: Source Codes Code Source 1 Customer 2 Peer Example: 3561:1xxxx customer route 3561:2xxxx peer route

"R" defines the region, as specified in Table 3-1. Codes 7 through 0 that are not defined yet and thus available for future region definitions. Since there are only four available region codes left, the definition of each code shall await a need for the function it would provide.

Regional Codes Code Region 1 North America (U.S.A and Canada) 2 Europe 3 Asia (including Japan) 4 Australia 5 South America 6 Middle East 7 Available for future region definitions 8 Available for future region definitions 9 Available for future region definitions 0 Available for future region definitions Example: 3561:11xxx customer, North America 3561:24xxx peer, Australia

"CCC" signifies country code defined by ISO 3166 codes for countries. Note: Peers use a country code of "000".

Example: 3561:11840 customer, North America, United States
3561:22000 peer, Europe, Italy

Country Country Abbr. CCC Code

AFGHANISTAN AF 004
ALBANIA AL 008
ALGERIA DZ 012
AMERICAN SAMOA AS 016
ANDORRA AD 020
ANGOLA AO 024
ANGUILLA AI 660
ANTARCTICA AQ 010
ANTIGUA AND BARBUDA AG 028
ARGENTINA AR 032
ARMENIA AM 051
ARUBA AW 533
AUSTRALIA AU 036
AUSTRIA AT 040
AZERBAIJAN AZ 031
BAHAMAS BS 044
BAHRAIN BH 048
BANGLADESH BD 050
BARBADOS BB 052
BELARUS BY 112
BELGIUM BE 056
BELIZE BZ 084
BENIN BJ 204
BERMUDA BM 060
BHUTAN BT 064
BOLIVIA BO 068
BOSNIA AND HERZEGOWINA BA 070
BOTSWANA BW 072
BOUVET ISLAND BV 074
BRAZIL BR 076
BRITISH INDIAN OCEAN TERRITORY IO 086
BRUNEI DARUSSALAM BN 096
BULGARIA BG 100
BURKINA FASO BF 854
BURUNDI BI 108
CAMBODIA KH 116
CAMEROON CM 120
CANADA CA 124
CAPE VERDE CV 132
CAYMAN ISLANDS KY 136
CENTRAL AFRICAN REPUBLIC CF 140
CHAD TD 148
CHILE CL 152
CHINA CN 156
CHRISTMAS ISLAND CX 162
COCOS (KEELING) ISLANDS CC 166
COLOMBIA CO 170
COMOROS KM 174
CONGO CG 178
CONGO, THE DEMOCRATIC REPUBLIC OF THE CD 180
COOK ISLANDS CK 184
COSTA RICA CR 188
COTE D'IVOIRE CI 384
CROATIA (local name: Hrvatska) HR 191
CUBA CU 192
CYPRUS CY 196
CZECH REPUBLIC CZ 203
DENMARK DK 208
DJIBOUTI DJ 262
DOMINICA DM 212
DOMINICAN REPUBLIC DO 214
EAST TIMOR TP 626
ECUADOR EC 218
EGYPT EG 818
EL SALVADOR SV 222
EQUATORIAL GUINEA GQ 226
ERITREA ER 232
ESTONIA EE 233
ETHIOPIA ET 231
FALKLAND ISLANDS (MALVINAS) FK 238
FAROE ISLANDS FO 234
FIJI FJ 242
FINLAND FI 246
FRANCE FR 250
FRANCE, METROPOLITAN FX 249
FRENCH GUIANA GF 254
FRENCH POLYNESIA PF 258
FRENCH SOUTHERN TERRITORIES TF 260
GABON GA 266
GAMBIA GM 270
GEORGIA GE 268
GERMANY DE 276
GHANA GH 288
GIBRALTAR GI 292
GREECE GR 300
GREENLAND GL 304
GRENADA GD 308
GUADELOUPE GP 312
GUAM GU 316
GUATEMALA GT 320
GUINEA GN 324
GUINEA-BISSAU GW 624
GUYANA GY 328
HAITI HT 332
HEARD AND MC DONALD ISLANDS HM 334
HOLY SEE (VATICAN CITY STATE) VA 336
HONDURAS HN 340
HONG KONG HK 344
HUNGARY HU 348
ICELAND IS 352
INDIA IN 356
INDONESIA ID 360
IRAN (ISLAMIC REPUBLIC OF) IR 364
IRAQ IQ 368
IRELAND IE 372
ISRAEL IL 376
ITALY IT 380
JAMAICA JM 388
JAPAN JP 392
JORDAN JO 400
KAZAKHSTAN KZ 398
KENYA KE 404
KIRIBATI KI 296
KOREA, DEMOCRATIC PEOPLE'S REPUBLIC OF KP 408
KOREA, REPUBLIC OF KR 410
KUWAIT KW 414
KYRGYZSTAN KG 417
LAO PEOPLE'S DEMOCRATIC REPUBLIC LA 418
LATVIA LV 428
LEBANON LB 422
LESOTHO LS 426
LIBERIA LR 430
LIBYAN ARAB JAMAHIRIYA LY 434
LIECHTENSTEIN LI 438
LITHUANIA LT 440
LUXEMBOURG LU 442
MACAU MO 446
MACEDONIA, FORMER YUGOSLAV REPUBLIC OF MK 807
MADAGASCAR MG 450
MALAWI MW 454
MALAYSIA MY 458
MALDIVES MV 462
MALI ML 466
MALTA MT 470
MARSHALL ISLANDS MH 584
MARTINIQUE MQ 474
MAURITANIA MR 478
MAURITIUS MU 480
MAYOTTE YT 175
MEXICO MX 484
MICRONESIA, FEDERATED STATES OF FM 583
MOLDOVA, REPUBLIC OF MD 498
MONACO MC 492
MONGOLIA MN 496
MONTSERRAT MS 500
MOROCCO MA 504
MOZAMBIQUE MZ 508
MYANMAR MM 104
NAMIBIA NA 516
NAURU NR 520
NEPAL NP 524
NETHERLANDS NL 528
NETHERLANDS ANTILLES AN 530
NEW CALEDONIA NC 540
NEW ZEALAND NZ 554
NICARAGUA NI 558
NIGER NE 562
NIGERIA NG 566
NIUE NU 570
NORFOLK ISLAND NF 574
NORTHERN MARIANA ISLANDS MP 580
NORWAY NO 578
OMAN OM 512
PAKISTAN PK 586
PALAU PW 585
PALESTINIAN TERRITORY, OCCUPIED PS 275
PANAMA PA 591
PAPUA NEW GUINEA PG 598
PARAGUAY PY 600
PERU PE 604
PHILIPPINES PH 608
PITCAIRN PN 612
POLAND PL 616
PORTUGAL PT 620
PUERTO RICO PR 630
QATAR QA 634
REUNION RE 638
ROMANIA RO 642
RUSSIAN FEDERATION RU 643
RWANDA RW 646
SAINT KITTS AND NEVIS KN 659
SAINT LUCIA LC 662
SAINT VINCENT AND THE GRENADINES VC 670
SAMOA WS 882
SAN MARINO SM 674
SAO TOME AND PRINCIPE ST 678
SAUDI ARABIA SA 682
SENEGAL SN 686
SEYCHELLES SC 690
SIERRA LEONE SL 694
SINGAPORE SG 702
SLOVAKIA (Slovak Republic) SK 703
SLOVENIA SI 705
SOLOMON ISLANDS SB 090
SOMALIA SO 706
SOUTH AFRICA ZA 710
SOUTH GEORGIA & SOUTH SANDWICH ISLANDS GS 239
SPAIN ES 724
SRI LANKA LK 144
ST. HELENA SH 654
ST. PIERRE AND MIQUELON PM 666
SUDAN SD 736
SURINAME SR 740
SVALBARD AND JAN MAYEN ISLANDS SJ 744
SWAZILAND SZ 748
SWEDEN SE 752
SWITZERLAND CH 756
SYRIAN ARAB REPUBLIC SY 760
TAIWAN, PROVINCE OF CHINA TW 158
TAJIKISTAN TJ 762
TANZANIA, UNITED REPUBLIC OF TZ 834
THAILAND TH 764
TOGO TG 768
TOKELAU TK 772
TONGA TO 776
TRINIDAD AND TOBAGO TT 780
TUNISIA TN 788
TURKEY TR 792
TURKMENISTAN TM 795
TURKS AND CAICOS ISLANDS TC 796
TUVALU TV 798
UGANDA UG 800
UKRAINE UA 804
UNITED ARAB EMIRATES AE 784
UNITED KINGDOM GB 826
UNITED STATES US 840
UNITED STATES MINOR OUTLYING ISLANDS UM 581
URUGUAY UY 858
UZBEKISTAN UZ 860
VANUATU VU 548
VENEZUELA VE 862
VIET NAM VN 704
VIRGIN ISLANDS (BRITISH) VG 092
VIRGIN ISLANDS (U.S.) VI 850
WALLIS AND FUTUNA ISLANDS WF 876
WESTERN SAHARA EH 732
YEMEN YE 887
YUGOSLAVIA YU 891
ZAMBIA ZM 894
ZIMBABWE ZW 716


 

Applying BGP Community string with sample configuration

1. Get the latest BGP community string from your ISP/upstream provider or check new.CiscoNET.com web site.

2. Pick the best BGP community string for your traffic shaping plan (mainly incoming traffic). Most of ISPs are providing BGP community string with local preference and AS prepending option. Cannot tell which one is better than the other. It will depend on your global traffic shaping plan.

3. Follow the below commands ( Cisco only )

The below Sample configuration will tag the 10.0.0.0/24 route with [ISP AS]:120 or [ISP AS]:3 and will not tag any other routes.

router#config t
router(config)#ip bgp-community new-format
router(config)#access-list 10 permit 10.0.0.0 0.0.0.255
router(config)#access-list 10 deny any

router(config)#route-map [to-ISP] permit 10
router(config-route-map)#match ip address 10
router(config-route-map)#set community [ISP AS]:120 <---- using Local Preference

or

router(config-route-map)#set community [ISP AS]:3 <------- using AS prepending
router(config-route-map)#route-map [to-ISP] permit 20
router(config-route-map)#exit

router(config)#router bgp [xxxx] <------------------------------- xxxx = customer's ASN
router(config-router)#neighbor x.x.x.x send-community
router(config-router)#neighbor x.x.x.x route-map [to-ISP] out
router(config-router)#exit
router(config)#exit
router#copy running-config startup-config

 

4. And then, go to www.CiscoNET.com and pick one of route server on the map to see your announcement. If you are using AS prepending option, you will see your AS prepends on route servers. Sometime you might not see your route with particular ISP path.
In most of case it might not be any routing problem, just the route path was dropped at somewhere by BGP best path selection scheme. Try Oregon route server, if you can see your route. The Oregon route server is providing many possible and available paths between BGP speakers and neighbors.
If you don't see your route on there? check other route servers and also check your
BGP configuration. You might need to contact your upstream provider to check what they are learning BGP route from you.

 

 

* We do NOT support or maintain any BGP community string
** Contact ISP to get more detail information


]]>
chris.yoon@wirethink.com (ShowIPBGP) BGP Community List Wed, 16 Apr 2008 14:07:02 +0000
Qwest communication AS209 http://showipbgp.com/bgp-tools/bgp-community-list/94-qwest-communication-as209.html http://showipbgp.com/bgp-tools/bgp-community-list/94-qwest-communication-as209.html

Qwest communication AS209 BGP Routing Policy

Attention
This BGP Community string information might be outdated. Please contact Qwest communication AS209 to get more recent one. This BGP communites is ONLY for the customer who has BGP with Qwest communication AS209. Showipbgp.com is not maintaining this BGP Community string.

You must follow the BGP Policy indicated below in order to run BGP from your network. Qwest can set up BGP Routing for you if you are dual homed to Qwest, or multi-homed to another provider.

In order to run BGP, please adhere to the following rules. You must have the following:
 

    • AS number from ARIN
    • be multi-homed to run BGP
    • IOS 10.3 or higher to run BGP (Do not turn up new BGP sessions with less than version 10.3).
    • No unfiltered redistribution from interior routing into BGP by you.
    • Explicit distribute-list or network statements should be used to prevent injections of invalid routes into global tables.
    • No redistribution from BGP into customers interior routing protocols. This will corrupt the as-path information.
    • As-paths filters preventing leakage of routing information from customer’s other service provider to us and vice versa. Filters should be inclusive rather than exclusive (i.e. they should list customer as-es instead of excluding other provides as-es).
    • IP Blocks for several specific routes should be aggregated into larger routes as much as possible.
    • Networks listed in configuration should be private (i.e. no network assigned to other customers, subnets should never be annouced outside,etc.)
    • Customers will not be permitted to use ‘*’ wildcards in their requested route filters.
    • Not allowed to run EBGP Multi-hop. The only except will be for load balancing purposes between the loopback addresses of the customer and Qwest routers that share multiple serial connections.
    • Qwest reserves the right to aggregate any annoucement for a network smaller than /19 when advertising to external peers UUnet, Sprint, AT&T) occurs.


 

Requirements and conditions

 

1. Multi-homing is a requirement to run BGP with Qwest. You must have at least one other connection with Qwest or another service provider. If you are not multi-homed, static routing is more stable and will be favored.

2. An autonomous system number is required to run BGP. To obtain one, you must fill out an Autonomous System Number Template, available from ARIN at http://www.arin.net/templates/asntemplate.txt.

3. Qwest filters the prefixes announced via BGP from our customers. The filters are built automatically from prefix information customers register in the Internet Routing Registry. For more information on the IRR, please go to http://www.merit.edu/radb/.

4. BGP can be a complicated protocol to configure and maintain. Qwest does not build or maintain customer BGP configurations.

5. Multi-homed customers must ensure that Qwest routes are not forwarded to their other service provider. In addition, BGP customers must ensure that routes from the other service provider are not announced to Qwest. AS based and/or prefix based filtering can be used to achieve this Protection.

Here is an example of a configuration using both types of filters lists. Assuming a customer of Qwest with an AS# of 1234 has a connection to another service provider(AS#1) and the customer is in turn the service provider for another company with an AS# of 100. The customer owns the networks: 201.10.3.0 and 199.16.13.0


 
Commands Description
router bgp 1234 bgp configuration
neighbor 205.171.2.10 remote-as 209 eighbor config for Qwest peer
neighbor 205.171.2.10 distribute-list 1 out prefix based filter
neighbor 205.171.2.10 filter-list 2 out as based filter
neighbor 199.80.10.90 remote-as 1 neighbor config for other provider
various neighbor statements
neighbor 206.18.33.20 remote-as-100 neighbor config for downstream
various neighbor statements
ip as-path access-list 2 permit ^1234$ as filter permitting as 1234
ip as-path access-list 2 permit ^1234 100$ as filter permitting as 100
access-list 1 permit 201.10.3.0 prefix filter permitting 201.10.3.0
access-list 1 permit 199.16.13.0 prefix filter permitting 199.16.13.0


 

This example allows only the announcements of 201.10.3.0 and 199.16.13.0 to Qwest, and only if those routes come from AS 1234 or AS 100 through AS 1234

6. Bad routing information can be injected into routing tables if your internal routing protocol is simply redistributed into BGP. Please do not redistribute into BGP without explicit distribute-lists. A safer method uses BGP network statements.

7. Do not redistribute BGP into your internal routing protocol. This can lead to corrupt as-path information.

8. Due to the complexity of BGP, we request a copy of the BGP configuration from your router to check for any incompatibilities between the configurations.

9. In the event customer BGP announcements are adversely affecting the Qwest backbone, Qwest customers, or Qwest peers, Qwest reserves the right to filter customer announcements or to turn off the customer BGP peering session.

10. The bandwidth of the line, the model, cpu power, and memory of the customer router may affect the ability of Qwest to announce a full routing table to the customer. Qwest reserves the right to limit the set of routes announced to a customer if Qwest determines that the customer router will be unable to support the full routing table.



Customer Control of Qwest Backbone Routing

1. You can control the behavior of your announcements in our network by setting specific BGP community string in your BGP announcements to Qwest. The strings that can be set are as follows:


 
BGP Community String Local Preference Description
none 100 Default
209:90 90 Backup for another Qwest line
209:70 70 Backup for a line from another ISP
209:888 100 Advertised only on Qwest network. Routes
go to customers and are used on the backbone

 

These options allow you to customize the way routes are treated on theQwest backbone. When there is more than one announcement about a particular network, the route with the highest local preference is used.

209:90 - Backup Route
If you have a second line with Qwest for backup, setting the BGP community string 209:90 on your announcements over the second link sets the local preference to 90 on those backup routes. The primary link will have routes with a preference of 100, so they will be preferred over the backup routes if both are available. If the primary route became unavailable, the line with a local-preference of 90 will pick up the traffic. These BGP  communities can be set on a prefix by prefix basis, so a customer with two connections can use the 209:90 BGP community to favor certain routes over one link to Qwest and other routes over a different link to Qwest, with mutual backup.

209:70 - Off Qwest Backup Route
To back up a line from another provider, you could set your local preference to 70. This is less preferred than announcements from another provider, but should your line with the other provider become unavailable, the 209:70 tagged routes would pick up the traffic.

209:888 - On Qwest Announcements Only
The 209:888 BGP community string does not set any local preference, but instead prevents any routes with that tag from being announced to Qwest peers. This could be used if you have lines to other providers and would like your Qwest line to only be used for traffic to and from direct Qwest customers.

The following is an example of using these BGP community strings. We will assume the same customer as in the previous example has a second line with Qwest. The customer wishes to use this second line as a backup line for the two networks listed in the previous example. They also wish to use this line to backup two other networks that they are advertising from another provider.


 
Commands
 
Description
 
router bgp 1234 bgp configuration
neighbor 205.3171.4.14 remote-as 209 neighbor config for Qwest peer
neighbor 205.171.4.14 send-community Tells router to attach BGP community strings
neighbor 205.171.4.14 route-map sendcomm out route-map to set BGP community strings
access-list 1 permit 201.10.3.0 Specifies routes to be tagged
access-list 1 permit 199.16.13.0 Specifies routes to be tagged
access-list 2 permit 200.10.10.0 Specifies routes to be tagged
access-list 2 permit 200.11.11.0 Specifies routes to be tagged
route-map sendcomm permit 10 First step of route map
match ip address 1 Matches addresses in access list 1
set community 209:90 Sets BGP community string to 209:90
route-map sendcomm permit 20 Second step of route map
match ip address 2 Matches addresses in access list 2
set community 209:70 Sets BGP community string to 209:70
 

This example sets a BGP community string of 209:90 to the networks of 201.10.3.0 and 199.16.13.0. These networks are advertised on Qwest's network with a local preference of 90. This allows this line to be a backup for those two networks should the customers' other line become unavailable. It also sets a BGP community string of 209:70 to the networks of 200.10.10.0 and 200.11.11.0. This allows this line to be a backup for those two networks should the customers' line on the other provider become unavailable.



 

 

Applying BGP Community string with sample configuration

1. Get the latest BGP community string from your ISP/upstream provider or check new.CiscoNET.com web site.

2. Pick the best BGP community string for your traffic shaping plan (mainly incoming traffic).
Most of ISPs are providing community string with local preference and AS prepending
option. Cannot tell which one is better than the other. It will depend on your global traffic shaping plan.

3. Follow the below commands ( Cisco only )

The below Sample configuration will tag the 10.0.0.0/24 route with [ISP AS]:120 or [ISP AS]:3 and will not tag any other routes.
 

router#config t
router(config)#ip bgp-community new-format
router(config)#access-list 10 permit 10.0.0.0 0.0.0.255
router(config)#access-list 10 deny any

router(config)#route-map [to-ISP] permit 10
router(config-route-map)#match ip address 10
router(config-route-map)#set community [ISP AS]:120 <---- using Local Preference

or

router(config-route-map)#set community [ISP AS]:3 <------- using AS prepending
router(config-route-map)#route-map [to-ISP] permit 20
router(config-route-map)#exit

router(config)#router bgp [xxxx] <------------------------------- xxxx = customer's ASN
router(config-router)#neighbor x.x.x.x send-community
router(config-router)#neighbor x.x.x.x route-map [to-ISP] out
router(config-router)#exit
router(config)#exit
router#copy running-config startup-config


 

4. And then, go to www.CiscoNET.com and pick one of route server on the map to see your announcement. If you are using AS prepending option, you will see your AS prepends on route servers. Sometime you might not see your route with particular ISP path.
In most of case it might not be any routing problem, just the route path was dropped at somewhere by BGP best path selection scheme. Try Oregon route server, if you can see your route. The Oregon route server is providing many possible and available paths between BGP speakers and neighbors.
If you don't see your route on there? check other route servers and also check your
BGP configuration. You might need to contact your upstream provider to check what they are learning BGP route from you.

 

 

 

* We do NOT support or maintain any BGP community string
** Contact ISP to get more detail information


]]>
chris.yoon@wirethink.com (ShowIPBGP) BGP Community List Wed, 16 Apr 2008 14:06:18 +0000
Optus(Singtel) AS7474 http://showipbgp.com/bgp-tools/bgp-community-list/93-optussingtel-as7474.html http://showipbgp.com/bgp-tools/bgp-community-list/93-optussingtel-as7474.html

Optus(Singtel) AS7474 BGP Community Strings


Attention

This BGP Community string information might be outdated. Please contact Optus(Singtel) to get more recent one. This BGP communites is ONLY for the customer who has BGP with Optus(Singtel) AS7474. Also, Showipbgp.com is not maintaining this BGP Community string.


 

Things to note regarding the Looking Glass are as follows ;

  • There are 2 separate routers performing Looking Glass functions :

The Domestic Looking Glass router includes BGP routes for Optus Customers , Optus Internal , and National Peers only.

The International Looking Glass router includes BGP routes for Optus Customers , Optus Internal , and International Peers only



  • Important BGP Communities configured by Optus include the following :

BGP Community String 7474:1402 is used for Asian Routes
BGP Community String 7474:1403 is used for US Routes
BGP Community String 7474:1202 is used for NSW Customer Routes
BGP Community String 7474:1203 is used for VIC Customer Routes
BGP Community String 7474:1204 is used for QLD Customer Routes
BGP Community String 7474:1205 is used for SA Customer Routes
BGP Community 7String 474:1206 is used for WA Customer Routes

Customers can also override BGP Local Preference in AS7474 by announcing the following BGP Communities with their routes -

BGP Community String 7474:100 is used for Customer routes to set BGP Local Preference to 100 (the default Local Preference for customer routes)
BGP Community String 7474:90 is used for Customer routes to set BGP Local Preference to 90
BGP Community String 7474:80 is used for Customer routes to set BGP Local Preference to 80
BGP Community String 7474:70 is used for Customer routes to set BGP Local Preference to 70
 

  • These Routers do not have links into each Optus Router. They consist of simply a Ethernet interface to plug it into the network. As such, ping's & trace's will always take the same path. Ping's and trace's are only really useful for verifying IP connectivity to a host, and do not demonstrate accurately the path the packets will take from other routers in our network. RADB requests are done realtime by opening a port 43 connection to whois.radb.net and are not results from a local cached database or similar. nslookup, dig and all other DNS resolution is done off a DNS resolver at 202.139.124.225 where no domains are hosted (caching-only nameserver).

     

Applying BGP Community string with sample configuration


 
1. Get the latest BGP community string from your ISP/upstream provider or check new.CiscoNET.com web site.

2. Pick the best BGP community string for your traffic shaping plan (mainly incoming traffic). Most of ISPs are providing BGP community string with local preference and AS prepending option. Cannot tell which one is better than the other. It will depend on your global traffic shaping plan.

3. Follow the below commands ( Cisco only )

The below Sample configuration will tag the 10.0.0.0/24 route with [ISP AS]:120 or [ISP AS]:3 and will not tag any other routes.

router#config t
router(config)#ip bgp-community new-format
router(config)#access-list 10 permit 10.0.0.0 0.0.0.255
router(config)#access-list 10 deny any

router(config)#route-map [to-ISP] permit 10
router(config-route-map)#match ip address 10
router(config-route-map)#set community [ISP AS]:120 <---- using Local Preference

or

router(config-route-map)#set community [ISP AS]:3 <------- using AS prepending
router(config-route-map)#route-map [to-ISP] permit 20
router(config-route-map)#exit

router(config)#router bgp [xxxx] <------------------------------- xxxx = customer's ASN
router(config-router)#neighbor x.x.x.x send-community
router(config-router)#neighbor x.x.x.x route-map [to-ISP] out
router(config-router)#exit
router(config)#exit
router#copy running-config startup-config

 

4. And then, go to www.CiscoNET.com and pick one of route server on the map to see your announcement. If you are using AS prepending option, you will see your AS prepends on route servers. Sometime you might not see your route with particular ISP path.
In most of case it might not be any routing problem, just the route path was dropped at somewhere by BGP best path selection scheme. Try Oregon route server, if you can see your route. The Oregon route server is providing many possible and available paths between BGP speakers and neighbors.
If you don't see your route on there? check other route servers and also check your
BGP configuration. You might need to contact your upstream provider to check what they are learning BGP route from you.

 

* We do NOT support or maintain any BGP community string
** Contact ISP to get more detail information


]]>
chris.yoon@wirethink.com (ShowIPBGP) BGP Community List Wed, 16 Apr 2008 14:05:04 +0000
nLayer Communications AS4436 http://showipbgp.com/bgp-tools/bgp-community-list/92-nlayer-communications-as4436.html http://showipbgp.com/bgp-tools/bgp-community-list/92-nlayer-communications-as4436.html

nLayer Communications AS4436

Attention

This BGP Community string information might be outdated. Please contact nLayer Communications to get more recent one. This BGP communites is ONLY for the customer who has BGP with nLayer Communications AS4436. Showipbgp.com is not maintaining this BGP Community string.


 

Peer BGP Policies

This section describes the policies for routing announcements received from and announced to external eBGP peers and transits.
 

Multi Exit Discriminator (MED) Policy

MEDs received from peers will be ignored by default, unless prior arrangements have been made to confirm the quality of the values.

MEDs are announced by default, using good aggregates and meaningful values based on IGP costs. Peers may decide to honor these MEDs at their discretion.

Damping Policy

Routing flaps from eBGP peers may be progressively dampened, based on prefix lengths as describe in the table below. This is done to protect our network from the instabilities of other announcements on the Internet.

Prefix Length Filtering

Announcements received from peers are filtered against a list of bogon blocks, as well as by prefix length. The shortest prefix length which will be accepted from any network is a /5, the longest prefix length which will be accepted is a /24.

Outbound announcements from nLayer will never exceed /24 in length. All routes announced will be registered in the Internet Routing Registry (IRR) databases under the as-set AS-NLAYER.


 

Damping Policy
Prefix Length Half-life Reuse Limit Suppress Limit Max Suppress
/24 or longer 10 7000 10000 15
/20 - /23 5 7000 10000 10
/17 - /19 3 7000 10000 5
/16 or shorter 1 10000 15000 2


Customer BGP Policies

This section describes the policies for routing announcements received from and announced to customers speaking BGP, including information on how customers may use BGP community tags to influence nLayer routing policy for their announcements.

Receivable BGP Communities

Customers may influence nLayer routing policies by a number of BGP community tags which may be set on routes which they announce. These tags can control the propagation of routes, adjust the localpref assigned to them, and even null route traffic.

Announced BGP Communities

All routes announced to customers are tagged with the following information:

4436:TCRI

T The type of relationship that the route was learned through.

C The continent where the route was learned.

R The region where the route was learned, if in the US.

I Internal usage only.

IRR Filtering

All customers announcements are filtered against Internet Routing Registry (IRR) databases. BGP speaking customers will be expected to maintain current and correct IRR entries.

All nLayer announcements will be recorded under the as-set AS-NLAYER.

Receivable BGP Communities
 

Receivable BGP Communities
BGP Community String
 
Action
4436:1 Prepend 4436 to route
4436:2 Prepend 4436 4436 to route
4436:3 Prepend 4436 4436 4436 to route
4436:50 Set local preference to 50
4436:100 Set local preference to 100
4436:150 Set local preference to 150
4436:200 Set local preference to 200
4436:250 Set local preference to 250
4436:300 Set local preference to 300
4436:555 Null route (discard) traffic
4436:666 Do not export to anyone
4436:777 Do not export to transits
4436:888 Do not export to peers
4436:999 Do not export to customers


 
Special BGP Communities
BGP Community String
 
Action
ASN:1 Prepend 4436 to ASN
ASN:2 Prepend 4436 4436 to ASN
ASN:3 Prepend 4436 4436 4436 to ASN
ASN:666 Do not announce to ASN

 

 

Announced BGP Communities
Value Type Continent US Region
1 Public Peer North America NYC
2 Private Peer Europe IAD
3 Transit Asia ATL
4 Customer Australia ORD
5 Internal South America KCY
6   Middle East DFW
7     SEA
8     SJC
9     LAX


 
Local Preferences
Localpref Description
50 Depreferenced transit route
100 Default transit route
150 Depreferenced peering route
200 Default peering route
250 Depreferenced customer route
300 Default customer route
400 Default internal route





 
**Information source below to see recent update
http://www.nlayer.net/network/bgppolicies/
 


 

Applying BGP Community string with sample configuration

1. Get the latest BGP community string from your ISP/upstream provider or check new.CiscoNET.com web site.

2. Pick the best BGP community string for your traffic shaping plan (mainly incoming traffic). Most of ISPs are providing BGP community string with local preference and AS prepending option. Cannot tell which one is better than the other. It will depend on your global traffic shaping plan.

3. Follow the below commands ( Cisco only )

The below Sample configuration will tag the 10.0.0.0/24 route with [ISP AS]:120 or [ISP AS]:3 and will not tag any other routes.

router#config t
router(config)#ip bgp-community new-format
router(config)#access-list 10 permit 10.0.0.0 0.0.0.255
router(config)#access-list 10 deny any

router(config)#route-map [to-ISP] permit 10
router(config-route-map)#match ip address 10
router(config-route-map)#set community [ISP AS]:120 <---- using Local Preference

or

router(config-route-map)#set community [ISP AS]:3 <------- using AS prepending
router(config-route-map)#route-map [to-ISP] permit 20
router(config-route-map)#exit

router(config)#router bgp [xxxx] <------------------------------- xxxx = customer's ASN
router(config-router)#neighbor x.x.x.x send-community
router(config-router)#neighbor x.x.x.x route-map [to-ISP] out
router(config-router)#exit
router(config)#exit
router#copy running-config startup-config

4. And then, go to www.CiscoNET.com and pick one of route server on the map to see your announcement. If you are using AS prepending option, you will see your AS prepends on route servers. Sometime you might not see your route with particular ISP path.
In most of case it might not be any routing problem, just the route path was dropped at somewhere by BGP best path selection scheme. Try Oregon route server, if you can see your route. The Oregon route server is providing many possible and available paths between BGP speakers and neighbors.
If you don't see your route on there? check other route servers and also check your
BGP configuration. You might need to contact your upstream provider to check what they are learning BGP route from you.

 

* We do NOT support or maintain any BGP community string
** Contact ISP to get more detail information


]]>
chris.yoon@wirethink.com (ShowIPBGP) BGP Community List Wed, 16 Apr 2008 14:04:12 +0000
Level3 AS3356 http://showipbgp.com/bgp-tools/bgp-community-list/91-level3-as3356.html http://showipbgp.com/bgp-tools/bgp-community-list/91-level3-as3356.html

Level 3 AS3356 BGP Community Strings

Attention

This BGP Community string information might be outdated. Please contact Level3 AS3356 to get recent update. This BGP communites is ONLY for the customer who has BGP with Level3 AS3356. Showipbgp.com is not maintaining this BGP Community string.

 

Level 3 does not allow any part of 4.0.0.0/8 to be multihomed. If you are a customer who is currently using address space from 4.0.0.0/8 and if you need to multihome your network to another provider, please contact Level 3 for new address space which can be multihomed.
If you are a provider who has been asked to route a more-specific network block that is part of 4.0.0.0/8, please ask your customer to contact Level 3 to obtain a new network block. Level 3 will not accept advertisements for any networks that are part of 4.0.0.0/8 from any non-customer peer.

Note that the import/export designations above are a simplification of our actual policies which cannot be properly described given the limitations of RPSL
They would also be rather tedious to read if we denoted all of the common policy bits applied to every peer, so we have only noted the peer-specific bits.
We have also only documented our customer peers in this object at this time.



The following import actions are common to every Level 3 customer peering session:

- RFC1918 and other reserved networks and subnets are not permitted.
- Advertisements with reserved ASes in the path (ie 64512 - 65535) are not permitted.
- Prefixes shorter than /3 or longer than /28 are not permitted.
- Advertisements containing the AS of a network with which we have a non-customer peering relationship are not permitted (ie customers are not allowed to advertise transit for UUnet, CW, etc).
- Advertisements tagged with our own "internal use only" BGP communities (ie the city/country/region/etc BGP communities outlined below) will have all of their BGP communities stripped from them at ingress, and any BGP communities meant to affect localpref, prepending, etc are thus ignored.
- Prefixes not matching the per-peer import policy as documented above are not permitted.
- Localpref will be set to 100 by default, subject to modification based on received BGP communities as outlined below.
- A hard limit is placed on the number of routes a peer is allowed to announce to us. This number is based on their registered routes plus a bit of extra overhead.

 

The following import actions are common to every Level 3 non-customer peering session:

- RFC1918 and other reserved networks and subnets are not permitted.
- Advertisements with reserved ASes in the path (ie 64512 - 65535) are not permitted.
- Prefixes shorter than /3 or longer than /24 are not permitted.
- Any subnet of any Level 3 CIDR block (as documented in rs-Level3) is not accepted unless routing for the subnet in question has been explicitly requested by the multihomed customer in question.
- Advertisements tagged with our own "internal use" or "customer use" BGP communities (as outlined below) will have all of their BGP communities stripped from them at ingress.
- MEDs are overwritten unless special arrangements have been made.
- Peers who register their routes with meaningful policies may have a prefix filter applied based on this policy.
- Localpref is set to 86 or lower (depending on the nature of the facility over which the peering is taking place and several other factors).
- A hard limit is placed on the number of routes a peer is allowed to announce to us. This number is based on their registered routes or on a historical view of the number of routes they have been advertising plus a bit of extra overhead.

 

The following export actions are common to every Level 3 peering session:

- RFC1918 and other reserved networks and subnets are not announced.
- Advertisements with reserved ASes in the path (ie 64512 - 65535) are not announced.
- Prefixes shorter than /3 or longer than /24 are not announced.
- Any subnet of any Level 3 CIDR block (as documented in rs-Level3) is not announced unless routing for the subnet in question has been explicitly requested by the multihomed customer in question.
- Suppression and prepend actions as outlined in the BGP community list below are taken for announcements to non-customer peers.



BGP Communities applied at ingress
 

--------------------------------------------------------------------------------
prefix type BGP communities
--------------------------------------------------------------------------------

3356:123 - Customer route
 
3356:666 - Peer route
 

--------------------------------------------------------------------------------
error type BGP communities
--------------------------------------------------------------------------------
 

3356:911 - "internal use" BGP communities received from peer

--------------------------------------------------------------------------------
city BGP communities
--------------------------------------------------------------------------------
 

3356:2001 - CHI - Chicago
3356:2002 - SDG - San Diego
3356:2003 - LAX - Los Angeles
3356:2004 - DEN - Denver
3356:2005 - PHI - Philadelphia
3356:2006 - WDC - Washington DC
3356:2007 - DET - Detroit
3356:2008 - DAL - Dallas
3356:2009 - SFO - San Francisco
3356:2010 - NYC - New York City
3356:2011 - SJO - San Jose
3356:2012 - SEA - Seattle
3356:2013 - ATL - Atlanta
3356:2014 - HOU - Houston
3356:2015 - BOS - Boston
3356:2016 - MIN - Minneapolis
3356:2017 - HON - Honolulu
3356:2018 - WEE - Weehawken
3356:2019 - BAL - Baltimore
3356:2020 - CIN - Cincinnati
3356:2021 - STM - Stamford
3356:2022 - MIA - Miami
3356:2023 - TMP - Tampa
3356:2024 - ORL - Orlando
3356:2025 - STL - St Louis
3356:2026 - PHX - Phoenix
3356:2027 - RCH - Richmond
3356:2028 - MEM - Memphis
3356:2029 - SLC - Salt Lake City
3356:2030 - SAC - Sacramento
3356:2031 - RAL - Raleigh
3356:2032 - SAT - San Antonio
3356:2033 - LVG - Las Vegas
3356:2034 - CLT - Charlotte
3356:2035 - CLE - Cleveland
3356:2036 - OAK - Oakland
3356:2037 - NVL - Nashville
3356:2038 - TUS - Tustin
3356:2039 - NWR - Newark
3356:2064 - LON - London
3356:2065 - FRF - Frankfurt
3356:2066 - PAR - Paris
3356:2067 - AMS - Amsterdam
3356:2068 - BRU - Brussels
3356:2069 - DUS - Dusseldorf
3356:2070 - HAM - Hamburg
3356:2071 - BER - Berlin
3356:2072 - MUN - Munich
3356:2074 - MLN - Milan
3356:2075 - ZUR - Zurich
3356:2076 - STK - Stockholm
3356:2077 - MAD - Madrid
3356:2078 - GEN - Geneva
3356:2079 - MAN - Manchester
3356:2080 - DUB - Dublin
3356:2081 - COP - Copenhagen
3356:2082 - VIE - Vienna
3356:2083 - PRG - Prague
3356:2084 - WAW - Warsaw
 

--------------------------------------------------------------------------------
country BGP communities
--------------------------------------------------------------------------------
 

3356:500 - UK
3356:501 - Germany
3356:502 - France
3356:503 - Netherlands
3356:504 - Belgium
3356:505 - Italy
3356:506 - Switzerland
3356:507 - Sweden
3356:508 - Spain
3356:509 - Ireland
3356:510 - Denmark
3356:511 - Austria
3356:512 - Czech Republic
3356:513 - Poland
3356:575 - USA
3356:576 - Canada
 

--------------------------------------------------------------------------------
regional BGP communities
--------------------------------------------------------------------------------
 

3356:2 - Europe
3356:3 - North America
 



 

BGP Communities accepted from customers
 


--------------------------------------------------------------------------------
Customer traffic engineering (TE) notes
--------------------------------------------------------------------------------
 

BGP Communities allow suppress or prepend to peer AS, where
- peer AS has a peering connection to Level 3
- peer AS is not a customer of Level 3
 

--------------------------------------------------------------------------------
Customer traffic engineering BGP communities - Suppression
--------------------------------------------------------------------------------
 

64960:XXX - announce to AS XXX if 65000:0
65000:0 - announce to customers but not to peers
65000:XXX - do not announce at peerings to AS XXX
 

--------------------------------------------------------------------------------
Customer traffic engineering BGP communities - Prepending
--------------------------------------------------------------------------------
 

65001:0 - prepend once to all peers
65001:XXX - prepend once at peerings to AS XXX
65002:0 - prepend twice to all peers
65002:XXX - prepend twice at peerings to AS XXX
65003:0 - prepend 3x to all peers
65003:XXX - prepend 3x at peerings to AS XXX
65004:0 - prepend 4x to all peers
65004:XXX - prepend 4x at peerings to AS XXX
 

--------------------------------------------------------------------------------
Customer traffic engineering BGP communities - Regional
--------------------------------------------------------------------------------
 

Will only work for regional peers
64980:0 - announce to customers but not to EU peers
64981:0 - prepend once to all EU peers
64982:0 - prepend twice to all EU peers
64983:0 - prepend 3x to all EU peers
64984:0 - prepend 4x to all EU peers
 

--------------------------------------------------------------------------------
Customer traffic engineering BGP communities - LocalPref
--------------------------------------------------------------------------------
 

3356:70 - set local preference to 70
3356:80 - set local preference to 80
3356:90 - set local preference to 90
 

--------------------------------------------------------------------------------
Customer traffic engineering BGP communities - Blackhole
--------------------------------------------------------------------------------
 

3356:9999 - blackhole (discard) traffic

Traffic destined for any prefixes tagged with this
BGP community will be discarded at ingress to the Level 3
network. The prefix must be one permitted by the
customer's existing ingress BGP filter.
Support@Level3.comSupport@Level3.comThis e-mail address is being protected from spam bots, you need JavaScript enabled to view it may need to be contacted to allow
in some cases. For some router vendors the peering
must be changed to an eBGP multihop session.
Please contact support@Level3.comsupport@Level3.comThis e-mail address is being protected from spam bots, you need JavaScript enabled to view it with any questions
regarding this functionality.
 

--------------------------------------------------------------------------------
trouble: 24 Hour Call +44-08000-927-729
trouble: Abuse reports to abuse@eu.level3.netabuse@eu.level3.netThis e-mail address is being protected from spam bots, you need JavaScript enabled to view it
Peering issues to peering@eu.level3.netpeering@eu.level3.netThis e-mail address is being protected from spam bots, you need JavaScript enabled to view it
http://www.level3.com/



 

 

Applying BGP Community string with sample configuration


 
1. Get the latest BGP community string from your ISP/upstream provider or check new.CiscoNET.com web site.

2. Pick the best BGP community string for your traffic shaping plan (mainly incoming traffic). Most of ISPs are providing BGP community string with local preference and AS prepending option. Cannot tell which one is better than the other. It will depend on your global traffic shaping plan.

3. Follow the below commands ( Cisco only )

The below Sample configuration will tag the 10.0.0.0/24 route with [ISP AS]:120 or [ISP AS]:3 and will not tag any other routes.

 

router#config t
router(config)#ip bgp-community new-format
router(config)#access-list 10 permit 10.0.0.0 0.0.0.255
router(config)#access-list 10 deny any

router(config)#route-map [to-ISP] permit 10
router(config-route-map)#match ip address 10
router(config-route-map)#set community [ISP AS]:120 <---- using Local Preference

or

router(config-route-map)#set community [ISP AS]:3 <------- using AS prepending
router(config-route-map)#route-map [to-ISP] permit 20
router(config-route-map)#exit

router(config)#router bgp [xxxx] <------------------------------- xxxx = customer's ASN
router(config-router)#neighbor x.x.x.x send-community
router(config-router)#neighbor x.x.x.x route-map [to-ISP] out
router(config-router)#exit
router(config)#exit
router#copy running-config startup-config


 

4. And then, go to www.CiscoNET.com and pick one of route server on the map to see your announcement. If you are using AS prepending option, you will see your AS prepends on route servers. Sometime you might not see your route with particular ISP path.
In most of case it might not be any routing problem, just the route path was dropped at somewhere by BGP best path selection scheme. Try Oregon route server, if you can see your route. The Oregon route server is providing many possible and available paths between BGP speakers and neighbors.
If you don't see your route on there? check other route servers and also check your
BGP configuration. You might need to contact your upstream provider to check what they are learning BGP route from you.

 
 

 

* We do NOT support or maintain any BGP community string
** Contact ISP to get more detail information


]]>
chris.yoon@wirethink.com (ShowIPBGP) BGP Community List Wed, 16 Apr 2008 14:03:23 +0000