BGP Knowledge Base http://showipbgp.com/bgp-knowledge-base.html Tue, 21 Nov 2017 06:33:24 +0000 Joomla! 1.5 - Open Source Content Management en-gb How to configure BGP multi-hop on Cisco CRS router http://showipbgp.com/bgp-knowledge-base/169-how-to-configure-bgp-multi-hop-on-cisco-crs-router.html http://showipbgp.com/bgp-knowledge-base/169-how-to-configure-bgp-multi-hop-on-cisco-crs-router.html Here is quick step to configure BGP multi-hop on Cisco CRS router.

 

CRS# conf t
CRS(config)# router bgp 65501

CRS(config-bgp)# neighbor 10.10.10.2
CRS(config-bgp-nbr)# remote-as 2000
CRS(config-bgp-nbr)# password <MD5 password>
CRS(config-bgp-nbr)# ebgp-multihop 2
CRS(config-bgp-nbr)# update-source loopback0
CRS(config-bgp-nbr)# address-family ipv4 unicast
CRS(config-bgp-nbr-af)# route-policy xxxxx in
CRS(config-bgp-nbr-af)# exit

CRS(config)#router static
CRS(config-static)#address-family ipv4 unicast
CRS(config-static-afi)#10.10.10.2/32 TenGigE0/1
CRS(config-static-afi)#commit
CRS(config)#

]]>
chris.yoon@wirethink.com (ShowIPBGP) BGP Knowledge Sat, 15 May 2010 02:57:27 +0000
Sample BGP configuration for Cisco CRS with XR software http://showipbgp.com/bgp-knowledge-base/168-sample-bgp-configuration-for-cisco-crs-with-xr-software.html http://showipbgp.com/bgp-knowledge-base/168-sample-bgp-configuration-for-cisco-crs-with-xr-software.html Here is sample BGP configuration for Cisco CRS router with XR software

 

Cisco CRS# conf t
Cisco CRS(config)#
router bgp 65501

Cisco CRS(config-bgp)# neighbor 192.168.1.2
Cisco CRS(config-bgp-nbr)# remote-as 2000
Cisco CRS(config-bgp-nbr)# description "CRS BGP sample"
Cisco CRS(config-bgp-nbr)# password xxxxx
Cisco CRS(config-bgp-nbr)# address-family ipv4 unicast
Cisco CRS(config-bgp-nbr-af)# route-policy xxxx in
Cisco CRS(config-bgp-nbr-af)# maximum-prefix 5000 75
Cisco CRS(config-bgp-nbr-af)# commit

 ]]> chris.yoon@wirethink.com (ShowIPBGP) BGP Knowledge Sat, 15 May 2010 02:43:26 +0000 How to hide private ASN from ISP http://showipbgp.com/bgp-knowledge-base/167-how-to-hide-private-asn-from-isp.html http://showipbgp.com/bgp-knowledge-base/167-how-to-hide-private-asn-from-isp.html We know how to change peer ASN without changing BGP processor ID which might be private ASN. That is local-as commands is the one to replace ASN for outside of world. However, your BGP peer keep on sending private ASN or current BGP processor ID. Here is the magic command to fix it.

"neighbor x.x.x.x local-as yyy no-prepend replace-as"

From below example, we will use ASN 100 on R1 to peer with R5. After configured R1, we got following output.

 BGP_local_AS.png

 ]]> chris.yoon@wirethink.com (ShowIPBGP) BGP Knowledge Mon, 10 May 2010 19:12:43 +0000 How to configure BGP peer-session template http://showipbgp.com/bgp-knowledge-base/162-how-to-configure-bgp-peer-session-template.html http://showipbgp.com/bgp-knowledge-base/162-how-to-configure-bgp-peer-session-template.html Here is "How to configure BGP peer-session template"

[ Assignement ]

All 4 routers are in AS 100 and linked in same Ethernet segment.
Establish BGP sessions, using Loopback 0 interface. Use RIPv2 as IGP.
Use template name "common" and "ibgp" and follow below guides;

common - verizon 4
                password showipbgp

ibgp -       remote-as 100
                update-source loopback 0

[ IP Address Table ]

R1 - FastEthernet0/0 : 192.168.1.1/24
                 Loopback0 : 1.1.1.1/8
                 Loopback1 : 10.10.10.0/24

R2 - FastEthernet0/0 : 192.168.1.2/24
                 Loopback0 : 2.2.2.2/8
                 Loopback1 : 20.20.20.0/24

R3 - FastEthernet0/0 : 192.168.1.3/24
                 Loopback0 : 3.3.3.3/8
                 Loopback1 : 30.30.30.0/24

R4 - FastEthernet0/0 : 192.168.1.4/24
                 Loopback0 : 4.4.4.4/8
                 Loopback1 : 40.40.40.0/24

 

[ Network Outline ]

 Picture of bgp-peer-session

[ R1 ]

router rip
 version 2
 network 1.0.0.0
 network 192.168.1.0
!
router bgp 100
 template peer-session common
  password showipbgp
  version 4
 exit-peer-session
 !
 template peer-session ibgp
  remote-as 100
  update-source Loopback0
  inherit peer-session common
 exit-peer-session
 !
 no synchronization
 bgp log-neighbor-changes
 network 10.10.10.0 mask 255.255.255.0
 neighbor 2.2.2.2 inherit peer-session ibgp
 neighbor 3.3.3.3 inherit peer-session ibgp
 neighbor 4.4.4.4 inherit peer-session ibgp
no auto-summary

 

[ R2 ]

router rip
 version 2
 network 2.0.0.0
 network 192.168.1.0
!
router bgp 100
 template peer-session common
  password showipbgp
  version 4
 exit-peer-session
 !
 template peer-session ibgp
  remote-as 100
  update-source Loopback0
  inherit peer-session common
 exit-peer-session
 !
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.0 mask 255.255.255.0
 neighbor 1.1.1.1 inherit peer-session ibgp
 neighbor 3.3.3.3 inherit peer-session ibgp
 neighbor 4.4.4.4 inherit peer-session ibgp
no auto-summary

 

[ R3 ]

router rip
 version 2
 network 3.0.0.0
 network 192.168.1.0
!
router bgp 100
 template peer-session common
  password showipbgp
  version 4
 exit-peer-session
 !
 template peer-session ibgp
  remote-as 100
  update-source Loopback0
  inherit peer-session common
 exit-peer-session
 !
 no synchronization
 bgp log-neighbor-changes
 network 30.30.30.0 mask 255.255.255.0
 neighbor 1.1.1.1 inherit peer-session ibgp
 neighbor 2.2.2.2 inherit peer-session ibgp
 neighbor 4.4.4.4 inherit peer-session ibgp
no auto-summary

 

[ R4 ]

router rip
 version 2
 network 4.0.0.0
 network 192.168.1.0
!
router bgp 100
 template peer-session common
  password showipbgp
  version 4
 exit-peer-session
 !
 template peer-session ibgp
  remote-as 100
  update-source Loopback0
  inherit peer-session common
 exit-peer-session
 !
 no synchronization
 bgp log-neighbor-changes
 network 40.40.40.0 mask 255.255.255.0
 neighbor 1.1.1.1 inherit peer-session ibgp
 neighbor 2.2.2.2 inherit peer-session ibgp
 neighbor 3.3.3.3 inherit peer-session ibgp
no auto-summary

 

[Verifying]

R1#sh ip bgp template peer-session ibgp
Template:ibgp, index:2
Local policies:0x81, Inherited polices:0x2
This template inherits:
  common index:1 flags:0x0
Locally configured session commands:
 remote-as 100
 update-source Loopback0
Inherited session commands:
 version 4

R1#sh ip bgp
BGP table version is 15, local router ID is 10.10.10.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.10.0/24    0.0.0.0                  0         32768 i
*>i20.20.20.0/24    2.2.2.2                  0    100      0 i
*>i30.30.30.0/24    3.3.3.3                  0    100      0 i
*>i40.40.40.0/24    4.4.4.4                  0    100      0 i
 

R2#sh ip bgp template peer-session ibgp
Template:ibgp, index:2
Local policies:0x81, Inherited polices:0x2
This template inherits:
  common index:1 flags:0x0
Locally configured session commands:
 remote-as 100
 update-source Loopback0
Inherited session commands:
 version 4


R2#sh ip bgp
BGP table version is 20, local router ID is 20.20.20.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.10.10.0/24    1.1.1.1                  0    100      0 i
*> 20.20.20.0/24    0.0.0.0                  0         32768 i
*>i30.30.30.0/24    3.3.3.3                  0    100      0 i
*>i40.40.40.0/24    4.4.4.4                  0    100      0 i

 

R3#sh ip bgp template peer-session ibgp
Template:ibgp, index:2
Local policies:0x81, Inherited polices:0x2
This template inherits:
  common index:1 flags:0x0
Locally configured session commands:
 remote-as 100
 update-source Loopback0
Inherited session commands:
 version 4

R3#sh ip bgp
BGP table version is 7, local router ID is 30.30.30.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.10.10.0/24    1.1.1.1                  0    100      0 i
*>i20.20.20.0/24    2.2.2.2                  0    100      0 i
*> 30.30.30.0/24    0.0.0.0                  0         32768 i
*>i40.40.40.0/24    4.4.4.4                  0    100      0 i

 

R4#sh ip bgp template peer-session ibgp
Template:ibgp, index:2
Local policies:0x81, Inherited polices:0x2
This template inherits:
  common index:1 flags:0x0
Locally configured session commands:
 remote-as 100
 update-source Loopback0
Inherited session commands:
 version 4

R4#sh ip bgp
BGP table version is 5, local router ID is 40.40.40.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.10.10.0/24    1.1.1.1                  0    100      0 i
*>i20.20.20.0/24    2.2.2.2                  0    100      0 i
*>i30.30.30.0/24    3.3.3.3                  0    100      0 i
*> 40.40.40.0/24    0.0.0.0                  0         32768 i

 

]]>
chris.yoon@wirethink.com (ShowIPBGP) BGP Knowledge Wed, 20 Jan 2010 00:37:06 +0000
How to configure BGP peer-group http://showipbgp.com/bgp-knowledge-base/161-how-to-configure-bgp-peer-group.html http://showipbgp.com/bgp-knowledge-base/161-how-to-configure-bgp-peer-group.html Here is "How to configure BGP peer-group"

[ Assignement ]

All 4 routers are in AS 100 and linked in same Ethernet segment.
Establish BGP sessions, using Loopback 0 interface. Use RIPv2 as IGP.

[ IP Address Table ]

R1 - FastEthernet0/0 : 192.168.1.1/24
                 Loopback0 : 1.1.1.1/8
                 Loopback1 : 10.10.10.0/24

R2 - FastEthernet0/0 : 192.168.1.2/24
                 Loopback0 : 2.2.2.2/8
                 Loopback1 : 20.20.20.0/24

R3 - FastEthernet0/0 : 192.168.1.3/24
                 Loopback0 : 3.3.3.3/8
                 Loopback1 : 30.30.30.0/24

R4 - FastEthernet0/0 : 192.168.1.4/24
                 Loopback0 : 4.4.4.4/8
                 Loopback1 : 40.40.40.0/24

 

[ Network Outline ]

 picture for BGP-peer-group.png

[ R1 ]

router rip
 version 2
 network 1.0.0.0
 network 192.168.1.0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 10.10.10.0 mask 255.255.255.0
 neighbor ibgp peer-group
 neighbor ibgp remote-as 100
 neighbor ibgp password showipbgp
 neighbor ibgp update-source Loopback0
 neighbor ibgp version 4
 neighbor 2.2.2.2 peer-group ibgp
 neighbor 3.3.3.3 peer-group ibgp
 neighbor 4.4.4.4 peer-group ibgp
 no auto-summary

 

[ R2 ]

router rip
 version 2
 network 2.0.0.0
 network 192.168.1.0
 no auto-summary
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.0 mask 255.255.255.0
 neighbor ibgp peer-group
 neighbor ibgp remote-as 100
 neighbor ibgp password showipbgp
 neighbor ibgp update-source Loopback0
 neighbor ibgp version 4
 neighbor 1.1.1.1 peer-group ibgp
 neighbor 3.3.3.3 peer-group ibgp
 neighbor 4.4.4.4 peer-group ibgp
 no auto-summary

 

[ R3 ]

router rip
 version 2
 network 3.0.0.0
 network 192.168.1.0
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 30.30.30.0 mask 255.255.255.0
 neighbor ibgp peer-group
 neighbor ibgp remote-as 100
 neighbor ibgp password showipbgp
 neighbor ibgp update-source Loopback0
 neighbor ibgp version 4
 neighbor 1.1.1.1 peer-group ibgp
 neighbor 2.2.2.2 peer-group ibgp
 neighbor 4.4.4.4 peer-group ibgp
 no auto-summary

 

[ R4 ]

router rip
 version 2
 network 4.0.0.0
 network 192.168.1.0
 no auto-summary
!
router bgp 100
 no synchronization
 bgp log-neighbor-changes
 network 40.40.40.0 mask 255.255.255.0
 neighbor ibgp peer-group
 neighbor ibgp remote-as 100
 neighbor ibgp password showipbgp
 neighbor ibgp update-source Loopback0
 neighbor ibgp version 4
 neighbor 1.1.1.1 peer-group ibgp
 neighbor 2.2.2.2 peer-group ibgp
 neighbor 3.3.3.3 peer-group ibgp
 no auto-summary

 

[Verifying]

R1#sh ip bgp peer-group ibgp
BGP peer-group is ibgp,  remote AS 100
  BGP version 4
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP neighbor is ibgp, peer-group internal, members:
  2.2.2.2 3.3.3.3 4.4.4.4
  Index 0, Offset 0, Mask 0x0
  Update messages formatted 0, replicated 0
  Number of NLRIs in the update sent: max 0, min 0

R1#sh ip bgp
BGP table version is 15, local router ID is 10.10.10.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.10.10.0/24    0.0.0.0                  0         32768 i
*>i20.20.20.0/24    2.2.2.2                  0    100      0 i
*>i30.30.30.0/24    3.3.3.3                  0    100      0 i
*>i40.40.40.0/24    4.4.4.4                  0    100      0 i

 

R2#sh ip bgp peer-group ibgp
BGP peer-group is ibgp,  remote AS 100
  BGP version 4
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP neighbor is ibgp, peer-group internal, members:
  1.1.1.1 3.3.3.3 4.4.4.4
  Index 0, Offset 0, Mask 0x0
  Update messages formatted 0, replicated 0
  Number of NLRIs in the update sent: max 0, min 0

R2#sh ip bgp
BGP table version is 17, local router ID is 20.20.20.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.10.10.0/24    1.1.1.1                  0    100      0 i
*> 20.20.20.0/24    0.0.0.0                  0         32768 i
*>i30.30.30.0/24    3.3.3.3                  0    100      0 i
*>i40.40.40.0/24    4.4.4.4                  0    100      0 i
 

R3#sh ip bgp peer-group ibgp
BGP peer-group is ibgp,  remote AS 100
  BGP version 4
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP neighbor is ibgp, peer-group internal, members:
  1.1.1.1 2.2.2.2 4.4.4.4
  Index 0, Offset 0, Mask 0x0
  Update messages formatted 0, replicated 0
  Number of NLRIs in the update sent: max 0, min 0

R3#sh ip bgp
BGP table version is 15, local router ID is 30.30.30.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.10.10.0/24    1.1.1.1                  0    100      0 i
*>i20.20.20.0/24    2.2.2.2                  0    100      0 i
*> 30.30.30.0/24    0.0.0.0                  0         32768 i
*>i40.40.40.0/24    4.4.4.4                  0    100      0 i

 

R4#sh ip bgp peer-group ibgp
BGP peer-group is ibgp,  remote AS 100
  BGP version 4
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP neighbor is ibgp, peer-group internal, members:
  1.1.1.1 2.2.2.2 3.3.3.3
  Index 0, Offset 0, Mask 0x0
  Update messages formatted 0, replicated 0
  Number of NLRIs in the update sent: max 0, min 0

R4#sh ip bgp
BGP table version is 5, local router ID is 40.40.40.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.10.10.0/24    1.1.1.1                  0    100      0 i
*>i20.20.20.0/24    2.2.2.2                  0    100      0 i
*>i30.30.30.0/24    3.3.3.3                  0    100      0 i
*> 40.40.40.0/24    0.0.0.0                  0         32768 i

 

]]>
chris.yoon@wirethink.com (ShowIPBGP) BGP Knowledge Wed, 20 Jan 2010 00:34:49 +0000
How to configure secure BGP? http://showipbgp.com/bgp-knowledge-base/158-how-to-configure-secure-bgp.html http://showipbgp.com/bgp-knowledge-base/158-how-to-configure-secure-bgp.html This is the one of famous question my customers asking all the time. How to configure secure BGP? There are few ways to make robust BGP session. Keep it in your mind, ISP doesn't provide all below commands (Don't wasting time). They would configure MD5 hash for your link. 

1. Using MD5 password

MD5 setting is common and easy to implement.

Cisco_Router(config-router)#neighbor x.x.x.x password c1sc0

 

]]>
chris.yoon@wirethink.com (ShowIPBGP) BGP Knowledge Sun, 20 Sep 2009 18:54:56 +0000
BGP Tutorial for ISP customers - BGP community string from ISP http://showipbgp.com/bgp-knowledge-base/154-bgp-tutorial-for-isp-customers-bgp-community-string-from-isp.html http://showipbgp.com/bgp-knowledge-base/154-bgp-tutorial-for-isp-customers-bgp-community-string-from-isp.html Most of the decent size of ISP provides BGP community string for their customer. By using icon_BGP.pngBGP community string, you can control our announcement globally and it instantly affects your inbound traffic. In these days, modifying backbone routing policy in ISP is common. They don't want to loose their customer's traffic, so they apply BGP attribute to customer's announcement to avoid those traffic is leaving their backbone.

 

 

]]>
contactus@showipbgp.com (Administrator) BGP Knowledge Mon, 13 Jul 2009 21:20:24 +0000
BGP Tutorial for ISP customers - Configuring BGP http://showipbgp.com/bgp-knowledge-base/153-bgp-tutorial-for-isp-customers-configuring-bgp.html http://showipbgp.com/bgp-knowledge-base/153-bgp-tutorial-for-isp-customers-configuring-bgp.html To bring BGP session minimum requires a configuration is really simple.  Just three lines oficon_BGP.png BGP statement will bring BGP session.
This is kinds of important to know, when you are troubleshooting.  If BGP doesnt come up, just simplify BGP configuration. It is sometimes best troubleshooting steps.

 

]]>
contactus@showipbgp.com (Administrator) BGP Knowledge Mon, 13 Jul 2009 21:18:07 +0000
BGP Tutorial for ISP customers - Controlling inbound traffic http://showipbgp.com/bgp-knowledge-base/152-bgp-tutorial-for-isp-customers-controlling-inbound-traffic.html http://showipbgp.com/bgp-knowledge-base/152-bgp-tutorial-for-isp-customers-controlling-inbound-traffic.html Controlling inbound traffic is the most important consideration when you are configuring BGP. icon_BGP.pngIf you have more than one ISP links, definetely you need to make sure your BGP announcement is propagate to Internet. If you have only one link to the ISP, again you don't really need BGP. Simple static route statement should be taking care of your needs.
Redundancy, failover and load-balancing traffic those are few major reasons that you have multiple links to ISP. Your BGP announcement is directly affecting your inbound traffic. Yes, it kinds of confuse if you are not dealing with BGP daily basis. How you annouce your routes bring traffic on one of your uplinks.

 

]]>
contactus@showipbgp.com (Administrator) BGP Knowledge Mon, 13 Jul 2009 21:17:33 +0000
BGP Tutorial for ISP customers - Controlling outbound traffic http://showipbgp.com/bgp-knowledge-base/151-bgp-tutorial-for-isp-customers-controlling-outbound-traffic.html http://showipbgp.com/bgp-knowledge-base/151-bgp-tutorial-for-isp-customers-controlling-outbound-traffic.html Outbound traffic control is actually easier than you thought. If you have single ISP link, icon_BGP.pngall outbound traffic will obviously exit out the link. As I mentioned earlier, if you have single ISP link then you don't really need BGP. Probably you may have more questions, if you have more than two ISP links. Redundanacy and load-sharing would be biggest concerns.

 

 

]]>
contactus@showipbgp.com (Administrator) BGP Knowledge Mon, 13 Jul 2009 21:15:15 +0000